VG30D Voice Gateway System Test Configuration

From DocWiki

Jump to: navigation, search

Contents

Introduction

This page provides a reference configuration for Cisco VG30D Voice Gateway within a Cisco Unified Communications deployment. The information is based primarily on testing performed during Cisco Unified Communications system testing.

The intended audience should be able to perform system-level configuration of Cisco Unified Communications components and deployments and be familiar with the Cisco Unified Communications family of products.

TIP: Use VG30D Voice Gateway (Project Features Tested label) as a keyword to search for related test cases in System Test Results for IP telephony.

This topic does not contain detailed step-by-step procedures; for detailed information about installing, and configuring Cisco VG30D Voice Gateway, refer to the Cisco VG30D Voice Gateway documentation.

Design

The Cisco VG30D Voice Gateway is an ISDN unit that is designed to perform signaling and service reconciliation between two unlike ISDN signaling systems.

Cisco VG30D Voice Gateway typically gets deployed to attach the following:

  • A QSIG (or DPNSS) PBX to a DPNSS (or QSIG) network
  • A number of DPNSS PBXs to a QSIG network
  • A DPNSS PBX to a Q.931-based Public ISDN service

Figure 1 shows an Cisco VG30D Voice Gateway interfacing a PBX by using DPNSS protocol to the QSIG protocol.

Figure 1: Cisco VG30D Voice Gateway.

DPNSS-QSIG.jpg

For information on Cisco VG30D Gateway specific deployments and sites where system testing was performed, see Tested Deployments and Site Models for IP telephony.

Topologies

This section contains Cisco VG30D Gateway deployment scenario and call flows in system test environment.

Component Deployment

During Cisco Unified Communications 8.0(2) Release system testing, the Unified Communications Manager cluster in Site A is connected to DPNSS PBX through Cisco VG30D Gateway. Interworking with QSIG and DPNSS PBX is tested. QSIG PBX had a direct QSIG link toward Unified Communications Manager. The Cisco VG30D Gateway was used as a QSIG/ DPNSS converter to connect DPNSS PBX. The functionality tested in this topology is the Path Replacement for transferred redirected calls and the Call Back feature. No interoperability testing between the DPNSS PBX in Site A and the QSIG PBX was performed.

Figure 2: DPNSS PBX connected through Cisco VG30D Gateway in Site A.

VG30D.jpg

Call Flow Diagram

Example call flows for Cisco VG30D Gateway.

VG30D-call-flow.jpg

Configuration

This section provides the high-level tasks and related information for configuring Cisco VG30D Gateway. Default and recommended values specified in the product documentation were used during system testing, except as noted.

The following tables provide this information:

Configuration Tasks: List of high-level configuration tasks

System Test Specifics: System test variations from default values documented in the product documentation.

More Information: Links to product documentation for detailed configuration information related to the high-level tasks.

Configuration Task System Test Specific Configuration More information
DPNSS Basic Setting   http://www.cisco.com/en/US/docs/routers/access/vg30d/vg30duser/vg30dusermanage.html#wp1052878
Q.931 Configuration
Basic Settings
  http://www.cisco.com/en/US/docs/routers/access/vg30d/vg30duser/vg30dusermanage.html#wp1052932
MGCP Gateway configuration in GVA DPNSS Gateway See Sample MGCP Gateway Configuration section.  
Cisco MGCP E1 port configuration in MGCP Gateway See Sample MGCP Gateway Configuration section.  

Sample Cisco MGCP Gateway Configuration

gva-dpnss#sh run
Building configuration...



Current configuration : 4556 bytes
!
! Last configuration change at 09:42:29 UTC Sun Nov 29 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname gva-dpnss
!
boot-start-marker
boot system flash c3845-adventerprisek9-mz.124-24.6.11.PIA12
boot-end-marker
!
! card type command needed for slot/vwic-slot 0/0
logging buffered 51200 warnings
enable secret 5 $1$qbbQ$07VXbPG55BqylrkNRxBLQ0
!
no aaa new-model
!
!
!         
network-clock-participate slot 3 
network-clock-select 1 E1 3/1/0
network-clock-select 2 E1 3/0/0
network-clock-select 3 E1 3/0/1
!
dot11 syslog
ip source-route
ip cef
!
!
!
!
no ip domain lookup
ip host gva-sub2 10.10.30.6
ip host gva-sub1 10.10.30.70
ip host gva-pub 10.10.30.5
no ipv6 cef
!
multilink bundle-name authenticated
!
!         
isdn switch-type primary-5ess
!
voice-card 0
 dspfarm
!
voice-card 3
!
!
!
license udi pid CISCO3845-MB sn FOC11274YBW
archive
 log config
  hidekeys
username cisco privilege 15 secret 5 $1$r1fA$JzOIeh1yhYXx4Gc9be8Q4.
!         
redundancy
!
!
controller E1 3/0/0
 pri-group timeslots 1-31 service mgcp
!
controller E1 3/0/1
 pri-group timeslots 1-31 service mgcp
!
controller E1 3/1/0
 framing NO-CRC4 
 pri-group timeslots 1-31 service mgcp
!
controller E1 3/1/1
!
!
!         
interface GigabitEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
 ip address 10.10.39.30 255.255.255.252
 duplex auto
 speed auto
 media-type rj45
 !
!
interface GigabitEthernet0/1
 ip address 10.10.100.41 255.255.255.224
 duplex auto
 speed auto
 media-type rj45
 !
!
interface Serial3/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-qsig
 isdn timer T310 120000
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
 !
!
interface Serial3/0/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-qsig
 isdn timer T310 120000
 isdn overlap-receiving
 isdn protocol-emulate network
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
 !
!
interface Serial3/1/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
 !        
!
!
router eigrp 30
 network 10.10.39.28 0.0.0.3
 auto-summary
!
ip forward-protocol nd
ip http server
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip route 10.10.100.0 255.255.255.0 10.10.100.33
!
!
!
tftp-server flash c3845-adventerprisek9-mz.124-24.6.11.PIA12
!
control-plane
 !        
!
!
voice-port 3/0/0:15
 echo-cancel coverage 64
 cptone GB
!
voice-port 3/1/0:15
 echo-cancel coverage 64
 cptone GB
!
voice-port 3/0/1:15
 echo-cancel coverage 64
 cptone GB
!
ccm-manager redundant-host gva-sub2
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server gva-pub  
ccm-manager config
!
mgcp
mgcp call-agent gva-sub1 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 ecm
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
mgcp behavior g729-variants static-pt
!
mgcp profile default
!
!
dial-peer voice 1 pots
 shutdown
!
!
!         
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device. 
This feature requires the one-time use of the username "cisco" 
with the password "cisco". The default username and password have a privilege l.

Please change these publicly known initial credentials using SDM or the IOS CLI 
Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want to us 

For more information about SDM please follow the instructions in the QUICK STAR 
GUIDE for your router or go to http://www.cisco.com/go/sdm 
-----------------------------------------------------------------------
^C
!         
line con 0
 password lab
 logging synchronous
 login
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 password lab
 logging synchronous
 login
 transport input telnet
!
exception data-corruption buffer truncate
scheduler allocate 20000 1000
end

gva-dpnss#

Related Documentation

For related information about Cisco VG30D Gateway, see Cisco VG30D Voice Gateway Documentation at:

http://www.cisco.com/en/US/products/ps10601/tsd_products_support_series_home.html

Rating: 0.0/5 (0 votes cast)

Personal tools