Unified CCE Software Compatibility Matrix for 10.5(x)

From DocWiki

This is the approved revision of this page, as well as being the most recent.
Jump to: navigation, search

Go to: Compatibility Matrix for Unified CCE

Go to: Category:Unified Contact Center Enterprise


This compatibility matrix specifies all supported configurations and versions for Cisco Unified Contact Center Enterprise 10.5(1). The information in this compatibility matrix supersedes compatibility information in any other Cisco Unified Contact Center Enterprise documentation. If a configuration or version is not stated, that configuration or version is not supported.

Contents

Unified CCE 10.5(x) Product Sets

Central Controller version 10.5(x)
Unified CM IVR PG
Cisco Agent Desktop
CTI OS Server1,2
CTI OS
Desktop1
Unified
Intelligence
Center
Unified
WIM and EIM
Siebel CRM RSM Unified CCMP3 Remote
Expert
Mobile
(REM)
SocialMiner Finesse
IP-IVR CVP VVB

10.5(2)4

10.5(1)

10.6(1)

10.5(1)

10.0(1)

9.0(2)

11.5(1)5

11.0(1)5

10.5(1)

10.0(x)

9.0(x)

11.5(1)6

PG

10.5(x)

Cisco Agent Desktop

10.0(2)

10.0(1b)

CTI OS Server

10.5(1)

10.5(1)

10.0(x)

9.0(x)

11.5(1)

11.0(1)

10.5(1)

11.0(1)

9.0(2)

8.1(x)

10.0(1)

9.1(1)

9.0(1)

11.5(1)

11.0(1)

10.5(1)

11.5(1)

10.5(1)

11.5(1)7

11.0(1)

10.5(1)

10.0(1)

10.0(1)

9.0(1)

9.1(2)

9.1(1)

9.0(x)

8.5(x)

9.0(1)

9.0(x)

8.5(x)

1The PG, CTI Server, and CTI OS server versions must all be at the same major and minor version. Additionally, the PG, CTI Server, CTI OS Server, and CTI OS desktop versions cannot be higher than the Central Controller version.

2The Cisco Agent Desktop client and servers must all be at the same version. CTI Server, and CTI OS Server and the Cisco Agent Desktop clients and Cisco Agent Desktop server versions cannot be at a higher maintenance release than the PG, CTI Server, and CTI OS Server versions.

3Except Precision Queuing Configuration. Precision Queuing must be at the same version as Unified CCE. There is no forward compatibility.

4Unified CM 10.5(2) is compatible with Unified CCE version 10.5(1) ES 9 or above version including 10.5(2).

5CVP 11.x and above does not support CUCM 9.x and cannot be deplyed with CUCM 9.x.

6Cisco VVB is supported with the patch CVP10.5.1_ES23.exe.

7Finesse 11.5 is compatible with Unified CCE version 10.5(3) or above.

Note: There is no compatibility dependency between Unified CCE and MediaSense, however, there is a compatibility dependency between MediaSense and Unified CM. For more information on MediaSense, see the Unified CM Cisco MediaSense Compatibilty Matrix

Cisco Gateway Requirements

Hardware

Category Requirements
Hardware Options Supports 28xx, 38xx, AS5350xm, and AS5400xm gateways with a PVDM2 DSP card.

Supports ISR G2 gateways (29xx and 39xx) and ISR G3 gateways (44xx) with PVDM3 DSP card. Supports ASR 1K gateway with PVDM3 DSP card.


Software

Category Requirements
Software Options  AS5350XM

AS5400XM

15.0(1) M

15.1(4) M

ISR G1 28xx, 38xx 15.0(1) M

15.1(1) T

15.1(4) M

ISR G2 29xx, 39xx 15.1(4) M

15.2(2) T

15.2(3) T

15.2(4) M

15.3(3) M

15.4(3) M

15.5(3) M1

15.6(2)T

ISR G2 39xxE 15.1(4) M

15.2(2) T

15.2(3) T

15.2(4) M

15.3(3) M

15.4(3) M

15.5(3) M1

15.6(2)T

ASR 1000 IOS XE 3.10

IOS XE 3.13

IOS XE 3.15.1S

IOS XE 3.16

ISR G3 43xx

(4321, 4331, 4351)

ISR G3 44xx

(4431, 4451)

IOS XE 3.13

IOS XE 3.15

IOS XE 3.16

For Unified CVP gateway requirements, see the Hardware and System Software Specification for Cisco Unified Customer Voice Portal.

Additional Unified CCE 10.5(x) Notes

  • Outbound Option SIP Dialer: Requires Cisco Unified SIP Proxy Version 8.5(1) and later versions. Supports IOS Release as specified in the table above.
  • In Release 10.5(1), IOS Versions 15.4(3)M/15.4(3)S of Cisco CUBE, with the exception of CPA (call progress analysis), are supported with the SIP Outbound Dialer.
  • In Release 10.5(2), IOS Version 15.5(2)T and XE 3.15 on ISR G3 gateways are required to support Cisco UBE CPA.
    For Cisco Finesse feature information, including Outbound Option support, see the Finesse, Cisco Agent Desktop, and Cisco CTI OS Feature Comparison Guide.
  • Unified Communications Manager 10.5(x) is supported with a Unified CCE 10.5(x) Peripheral Gateway (PG) only. Unified CCE 10.5(x) Central Controller supports PGs running at the following versions for backward compatibility during upgrade: 10.0(x) and 9.0(x). For Unified Communications Manager compatibility for these PGs, see the Unified Communications Manager Compatibility Guide.
  • The following general limitations pertain to Unified CCE deployments that use the System Peripheral Gateways (PG): E-Mail Manager Option, Web Collaboration Option (both end-of-life products), as well as Cisco Unified Web and E-Mail Interaction Manager (Unified WIM and EIM) are not supported with deployments that use the System PG. For Unified WIM and EIM documentation, see Cisco Unified Web Interaction Manager and Cisco Unified E-Mail Interaction Manager.

IOS Versioning Key, using 15.1(4)M3 and 15.1(4)T1 as examples:

  • 15.1 is the version number.
  • (4) is the release number.
  • M3 and T1 are the train release numbers. M is the mainline train and T is the technology train.
  • An increment in the release number after M or T refers to additional bug fixes.

Unified CVP supports the listed IOS release trains and their later M or T trains respectively. For example, gateways supporting 15.1(4)M3 will also support 15.1(4)M4 and 15.1(4)M7, but not 15.1(4)M1 and 15.1(4)M2.

Cisco Unified SIP Proxy

Supported Versions: Cisco Unified SIP Proxy 8.5(x) and 9.1(x).

IP Phone Support

Agent Telephone Voice Video RSM CUCM Silent Monitor Agent Greeting Whisper Announcement Specific Device Notes

C40

C60

C90

Telepresence

Yes Yes No No No No

MX300 G2

MX700

MX800

Telepresence

Yes Yes No No No No

SX10

SX20

SX80

Telepresence

Yes Yes No No No No
CTS-500 Telepresence Yes RE No No No No

CTS-500 TP is supported as a Remote Expert (RE) kiosk only.

EX60

EX90

Yes RE No No No No

EX60, EX90 are supported in Remote Expert (RE) solutions only.

DX650

DX70

DX80

(for Android)

Yes Yes No Yes Yes Yes

Join Across Line (JAL) and Direct Transfer Across Line (DTAL) phone feature is not supported.

DX devices require cmterm-devicepack10.5.1.11009-1.cop.sgn applied to CUCM.

9951

9971

Yes Yes Yes Yes Yes Yes

Join Across Line (JAL) and Direct Transfer Across Line (DTAL) phone feature is not supported.

Video Prompt/Queue is not supported.

Finesse 9.1(x) supported with caveats mentioned in Cisco Finesse 9.1(1) Release Notes.

8941

8945

8961

Yes Yes Yes Yes Yes Yes

Join Across Line (JAL) and Direct Transfer Across Line (DTAL) phone feature is not supported.

Video Prompt/Queue is not supported.

Finesse 9.1(x) supported with caveats mentioned in Cisco Finesse 9.1(1) Release Notes.

8845

8865

Yes Yes Yes Yes Yes Yes


8811

8841

8851

8851NR

8861

Yes No Yes Yes Yes Yes

Join Across Line (JAL) and Direct Transfer Across Line (DTAL) phone feature must be disabled.
8811 requires cmterm-devicepack10.5.1.11012.cop.sgn applied to CUCM.

7975

Yes

No

Yes

Yes

Yes

Yes

7962, 7965

Yes

No

Yes

Yes

Yes

Yes


7942, 7945

Yes

No

Yes

Yes

Yes

Yes


7925

Yes No Yes No No No

Finesse is not supported with 7925.

7821

7841

7861

Yes No Yes Yes Yes Yes

6921

6941

6945

6961

Yes No Yes Yes Yes Yes

Cisco IP Communicator

8.6(x)

7.0(x)

Yes

Yes

No

No

Yes

Yes

Yes

Yes

Yes

No

Yes

No

Mobile Agents are not supported with Cisco IP Communicator.

CAD IP Phone Agent is not supported with Cisco IP Communicator.

Jabber for Windows 9.7 and higher Yes Yes Voice-only Voice-only No Yes

The only supported desktops are Finesse 10.x and CTI OS 10.x.

Jabber for Mac 9.6 and higher Yes Yes Voice-only Voice-only No Yes

The only supported desktops are Finesse 10.x and CTI OS 10.x.

Jabber for VXME 9.7 and higher Yes No Yes Yes No Yes

The only supported desktops are Finesse 10.x and CTI OS 10.x.

The Cisco Unified Contact Center Enterprise Design Guide includes details about caveats and features associated with each of these specific phone devices.

The following general limitations pertain to IP phones used with Unified CCE Enterprise deployments:

  • Only Cisco IP Phones are supported as contact center agent phones. As an alternative, you may choose to deploy the Mobile Agent solution to enable Cisco Unified CCE and Contact Center Hosted (CCH) to use any phone as an agent phone. Please consult with your Cisco Sales Engineer for additional detail on this configuration.
  • See the Cisco Unified Communications Manager Compatibility Guide for SIP and other phone protocol support.


Third-party Software

  • Unified CCE 10.5(1) comes with pre-installed .NET version 4.0. Since .Net 4.0, 4.5 and 4.5.1 are no longer supported by Microsoft. Unified CCE 10.5(2) supports .NET version 4.5.2 starting release 10.5(2). The .NET version 4.5.2 has to be installed manually.
  • Unified CCE Administration client 10.5(1) installs .NET version 4.0 on Windows 7/Windows Server 2008 R2 and .NET version 4.5.1 on Windows 8 system. Unified CCE Administration client 10.5(2) supports .NET version 4.5.2. The .NET version 4.5.2 has to be installed manually.


Note: Unless explicitly mentioned, upgrading any third-party software that is bundled along with Unified CCE such as Java or Tomcat, is not supported. For example, upgrading Java from 6 to 7 on ICM servers is not supported.


http://docwiki-dev.cisco.com/w/index.php?title=Unified_CCE_Solution_Compatibility_Matrix_for_11.0(x)&action=edit


Microsoft System Software Requirements

Microsoft Windows Server 2008 R2

Microsoft Windows Server 2008 R2 is supported. Be aware of the following distinction between the editions.

IMPORTANT: Currently only SP1 for Microsoft Windows Server 2008 R2 is supported.

Microsoft Windows Server 2008 R2 Standard Edition

  • Supports up to four processors on one 64-bit server
  • Maximum 32 GB of RAM

Microsoft Windows Server 2008 R2 Enterprise Edition

  • Supports up to eight processors on one 64-bit server
  • Maximum 2 Terabytes (TB) of RAM

IMPORTANT: Unified ICM/CCE is qualified to work only on a standard packaged installation of Microsoft Windows Server 2008 R2 (Standard or Enterprise). Cisco does not support Unified ICM/CCE on a customized Windows image (for example, a corporate image). If you use a customized image of the Windows operating system, the Unified ICM/CCE application can fail.

Internet Script Editor

Internet Script Editor (ISE) supports Windows Server 2008 R2, Windows 7, and Windows 8.1 (Professional and Enterprise)

Note: In order for ISE to work properly, the "Enable HTTP Keepalive" box on the web site tab of Internet Information Services Manager/Default Web Site Properties needs to be checked.

Microsoft Windows Active Directory

Cisco Unified ICM and Unified CCE support Microsoft Windows Active Directory on:

  • Windows Server 2003
  • Windows Server 2008
  • Windows Server 2012*

*NOTE: If you are integrating the Unifed CCE servers to Windows Server 2012 based domain controller, then you need to apply a hotfix to the Unified CCE servers. The hotfix ensures that you can map the following security identifiers (SIDs):

  • S-1-18-1 Authentication authority asserted identity
  • S-1-18-2 Service asserted identity

Some applications, such as the User Migration Tool, use these SIDs and may fail. To resolve this issue, install the hotfix on the Windows Server 2008 R2-based computers in the domain. See http://support.microsoft.com/kb/2830145/en-us.


Microsoft SQL Server 2008 R2

Microsoft SQL Server 2008 R2 Standard Edition

  • CPU: Supports up to four processors on one server
  • RAM: No operating system maximum
  • SP2
  • SP3

Microsoft SQL Server 2008 R2 Enterprise Edition

  • CPU: No operating system maximum
  • RAM: No operating system maximum
  • SP2
  • SP3


Microsoft Windows and Microsoft SQL Server Localization Support

The following table lists supported localized versions of Microsoft Windows Server and SQL Server that you can use with Cisco Unified ICM/Unified Contact Center Enterprise and Hosted system components.

Supported Microsoft Software Localizations
Microsoft Windows Server 2008 R2 Microsoft SQL Server 2008 R2 SQL Collation Setting
Danish
Latin1_General
Dutch
Finnish
French French
German German
Italian Italian
Norwegian
Portuguese (Brazil) Portuguese (Brazil)
Spanish Spanish
Swedish
Chinese (simplified) Chinese (simplified) Chinese_PRC
Chinese (traditional) Chinese (traditional) Chinese_Taiwan_Stroke
Japanese Japanese Japanese
Korean Korean Korean_Wansung
Polish
Polish
Russian
Cyrillic_General
Turkish
Turkish

If there is not a corresponding localized SQL Server 2008 (listed in the Microsoft SQL Server 2008 R2 column) for a particular language listed in the Microsoft Windows Server 2008 R2 column, use the English SQL Server 2008 with the applicable setting listed in the SQL Collation Setting column.

Cisco Unified Contact Center Enterprise and Cisco Packaged Content Center Enterprise both support multilingual versions of Microsoft Windows Server 2008 R2 (English Windows Server 2008 with language packs installed). For details about how to set up multilingual versions of Microsoft Windows Server 2008 R2, see the Cisco Unified Contact Center Enterprise Installation and Upgrade Guide.

Use English SQL Server 2008 on multilingual versions of the Microsoft Windows Server 2008 R2 environment. Following are two valid examples of supported multilingual environments:

  • English Windows Server 2008 with Japanese Windows language pack installed, and English SQL Server 2008 with Japanese SQL Collation Setting.
  • English Windows Server 2008 with Russian Windows language pack installed, and English SQL Server 2008 with Cyrillic_General SQL Collation Setting.


Transport Layer Security (TLS)

All VOS based components (Finesse, Unified Intelligence Center, Live Data, and SocialMiner) support TLS 1.0 and 1.1. It is only for communication between servers and end clients of servers. It does not include communications between VOS servers and external servers. (e.g. CUIC scheduler does not support TLS/SSL/STARTTLS).

(CUIC uses standard SMTP on port 25 to communicate with external SMTP servers)

Unified CCE and packaged CCE supports TLS 1.0, TLS 1.1 and TLS 1.25. All VOS based components (Finesse, Unified Intelligence Center, Live Data and SocialMiner support TLS 1.0 and TLS 1.1).

5TLS 1.2 support has been added in ver 10.5(3).

Java Requirements

Unified CCE Release 10.5 installs with 32 bit Java 6 Update 30 and can be upgraded to the latest Java 6 update. Java 7 is not supported.


Operating System and Database Requirements

The following table presents operating system requirements that are specific to the Unified ICM/CCE server type. The next table covers Unified ICM/CCE servers and client desktop deployments that require special consideration.

Operating System and Database Requirements, Unified ICME/ICMH/CCE/CCH
Unified ICM/CCE Server Microsoft Windows Server 2008 R2 MS SQL Server 2008 R2
ICM Router
NAM Router
CICM Router
Progger (Unified CCE)
Rogger (Unified CCE)
NAM Rogger (Unified CCH)
Administration & Data Server
All PGs; includes:
  • CCE Agent PG
  • TDM ACD PG
  • VRU PG
  • MR PG
  • Outbound Option Dialer
1
Unified CCE Gateway PG
ICM Logger
NAM Logger
CICM Logger
HDS & DDS

1SQL Server is not required unless Cisco Agent Desktop is installed.



Special Considerations (OS and DB Requirements), Unified ICME/ICMH/CCE/CCH
Unified ICM/CCE Server Operating System Requirements
Administration Client Requires Windows 7, Windows 8.1 (Professional and Enterprise), or Windows Server 2008 R21 .
Unified Intelligence Center Client See the Cisco Unified Intelligence Center documentation.
CTI OS Desktops See CTI Supported Platforms.
CTI OS See CTI Supported Platforms.

1Unified CCE release 10.5(2) ES 20 supports Administration client on Windows 2008 R2. You need to download the latest Unified CCE 10.5(1) Administration client installer and install it along with the Unified CCE 10.5(2) MR Patch.

CTI Supported Platforms

CTI Option Operating System
Microsoft Windows Server 2008 R2 (SP1) Windows XP Professional; SP2 Windows XP Professional; SP3 Windows 7 (Pro, Enterprise, and Ultimate)1 Windows 8
Mac OS X
CTI OS Server
                    —
    —
Cisco Data Store
                     —
    —
Silent Monitor Server (standalone)
                     —
    —
Silent Monitor Service for Unified CCE Toolkit
                     √
    —
CTI Driver for Siebel
                     —
    —
CTI OS - CTI toolkit Supervisor Desktop
                     √
    —
CTI OS - CTI toolkit Agent Desktop
                      √
    —
CTI OS - CTI toolkit Combo Desktop .NET
                      √
    —
CTI OS - Custom Apps using C++ or COM CIL
                      √
    —
CTI OS - Custom Apps using Java CIL
                      √
    —
√ (V5.0)
CTI OS - Custom Apps using .NET CIL
                      √
    —
CTI OS - Monitor Mode Apps using C++, COM, or .NET CIL
                      √
    —
CTI OS - Monitor Mode Apps using Java CIL
                      √
    —
√ (V5.0)
Cisco Agent Desktop
                      √
    √
√ (v4.0 or 5.0)
Cisco Finesse

                      √
    √

1Any customizations to the CTI OS toolkit must be compiled under the development environment supported in Release 10.0(1) and then deployed on Windows 7. For further information, see the CTI OS Developer Guide. You can move existing customized CTI OS desktops from Windows 2012 to Windows 7 without the need for recompilation. Windows Server 2008 is not supported.

Supported Third-Party Software

Function Software
Remote Administration For Remote Desktop usage information, see the "Remote Administration” section in the Security Best Practices Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.
Antivirus Software
  • McAfee Virus Scan Enterprise 8.8i
  • Symantec Endpoint Protection 11.0/12.1
  • Trend MicroServerProtect Version 5.7/5.8

Note: As customer, you are not allowed to upgrade Apache Tomcat on UCCE servers.


Unified CCE Release 10.5.(1) Supported Browsers

Release 10.5(1) components support:

  • Internet Explorer 11
  • Internet Explorer 10 (Finesse support for Internet Explorer 10 requires Finesse 10.5 ES1 or higher)
  • Internet Explorer 9
  • Firefox24 and higher (we make every effort to test and support the most recent versions of Firefox)

Exceptions to the browser compatibility are:

  • Administration Client Setup Tool (does not support Firefox)
  • Unified WIM and EIM 9.0(2) Agent Desktop and higher (does not support Firefox)
  • Unified WIM and EIM 9.0(2) Agent Desktop does not support Internet Explorer 11

Unified CCE Parent / Child PG Compatibility

Release
Parent PG 9.0(x) Parent PG 10.0(x) Parent PG 10.5(x)
Child PG 9.0(x) Yes
Yes
Yes
Child PG 10.0(x) Yes
Yes
Yes
Child PG 10.5(x) Yes
Yes
Yes


Central Controller Backward Compatibility

CentralController PG PG + CAD
10.5 10.0  10.0
10.5 9.0 9.0

Note: Backward compatible PGs are supported during the transition while you upgrade the Central Controller and PGs to the same version.

Note: MR PG and Dialer must be at the same version.

NAM/CICM Compatibility

NAM Version CICM Version
10.5 10.0
10.5 9.0

Note: You can switch the columns for forward compatibility. For example, CICM at 10.5 and NAM at 10.0 is a supported configuration.

VDI Support

Cisco Client Type Version Virtual Desktop Infrastructure OS Compatibility
CTI-OS Clients (All CILs) 8.5(x), 9.0, 10.0(1), 10.5(x) VMware View 4.6, 5.0 Windows 7 32 bit - Supported
Windows 7 WoW64 - Supported
Windows XP 32 bit - Supported
CTI-OS Clients (All CILs) 8.5(x), 9.0, 10.0(1), 10.5(x) Citrix XenDesktop 5.0, 5.5 or 6.0 Windows 7 32 bit - Supported
Windows 7 WoW64 - Supported
Windows XP 32 bit - Supported
CTI-OS Clients (All CILs) 8.5(4), 9.0(2), 10.0(1), 10.5(x) Citrix XenDesktop 5.0, 5.5, 6.0, 6.5 Windows 7 32 bit - Supported
Windows 7 WoW64 - Supported
Windows XP 32 bit - Supported
Cisco Finesse 10.0(1) & 10.5(1)

VMware View 4.6, 5.x and 6.0

Horizon View 6.0

Windows 7 (32 bit, 64 bit, and WOW64)

Windows 8.1 (Finesse 10.5 Only)

Cisco Finesse 10.0(1) & 10.5(1) Citrix XenDesktop 4.x, 5.0, 5.5, 6.0, 6.5, 7.0, 7.1, 7.5, 7.6 Windows 7 (32 bit, 64 bit, and WOW64)

Windows 8.1 (Finesse 10.5 Only)

Cisco Agent Desktop (CAD) All Not Supported Not Supported

Notes:

  • Unified Communications Manager Silent Monitoring is the only type of Silent Monitoring that is supported with VXI/VDI.
  • Desktop solutions are only supported on PC-like devices that utilize a keyboard and mouse (no tablets or mobile devices supported currently).
  • The customer is not required to use Cisco VXI endpoints in a VDI solution. The customer can use any VDI endpoint that supports the specific Citrix or VMware VDI solution versions supported by Cisco. The customer must ensure that bandwidth and any other deployment considerations ensure that the solution can meet the performance and timing requirements of CTI-OS.
  • For information about Cisco Agent Desktop with thin client and virtual desktop environments, see the Integrating Cisco Agent Desktop with Thin Client and Virtual Desktop Environments document.
  • Cisco Unified Contact Center Enterprise Administration is not supported on virtual desktops.
  • Cisco Unified Intelligence Center (CUIC) is not validated on virtual desktops and is not currently supported, however if specific CUIC issues occur on virtual desktops and are reproducible in supported browsers (IE, Chrome, and Firefox), those issues will be addressed.


Application Virtualization

Cisco Client Version Unified CCE Version Citrix/XenApp Remote Desktop Services platform
CTI-OS Clients (All CILs) 10.5(1) XenApp 6.0 Windows Server 2008 R2 (SP1)
Cisco Finesse 10.5(1) XenApp 6.5, 7.5, 7.6 Windows Server 2008 R2 (SP1)


Siebel Compatibility

Cisco Siebel Driver Siebel Release
10.5(1) 8.1(x)


ICM-to-ICM Gateway Compatibility

ICM1 ICM2
10.5
10.0
10.5 9.0


Note: The columns can be switched for forward compatibility. For example, ICM2 at 10.5 and ICM1 at 10.0 is a supported configuration.

Other Product Sets

Unified ICM ACD 10.5 Product Sets

Aspect Call Center w/CMI

Switch Version CMI (Contact Server) ICM 10.5 Notes
v8.02 CMI v5.1.1

v8.3 CMI v5.1.2

v8.3 CMI v5.2

v8.4 CMI v5.2
Aspect 8.4 and CMI 5.2 are End of Support (EOS) by Aspect.
v9.0 CMI v5.2
Aspect 9.0 and CMI 5.2 are EOS by Aspect.
v9.1 (Win2k3) CMI v5.2
Aspect 9.1 and CMI 5.2 are EOS by Aspect.
v9.1.1 CMI v5.2
Aspect 9.1.1 and CMI 5.2 are EOS by Aspect.
v9.2 CMI v5.2

v9.2 CMI v6.2.1

v9.3 1 CMI v5.2

v9.3 CMI v6.2.1

v9.3 CMI v6.3

v9.3 CMI v6.4 Yes CMI v6.4 is supported only on Win2k8.

1ICM supports four-digit Application IDs and CCT with Aspect Switch Version 9.3 from 7.5(9) onwards in the 7.5(x) stream and 8.0(2) onwards in the 8.(x) stream.

Note: DataInterLink with Application Bridge 6.0 is supported for all versions of ICM.



Avaya

When reviewing the support details in the Avaya matrixes below, consider the following notes and special considerations related to Avaya support:

  • Avaya Name Changes: Avaya changed names from DEFINITY to MultiVantage to Avaya Communications Manager (ACM) to Avaya Aura Communications Manager.
  • RTA 5.0.5 and RTA 6.0 enhanced functionality (60 skills per agent and 2000 skill groups per system) are not supported by ICM.
  • ICM currently does not support more than 12000 active associations on a single system.
  • All CMS versions are supported as long as a supported RTA is being used.
  • Cisco supports the Avaya S8300, S8400, S85XX, S87XX, and S88XX Servers in support of ACM.
  • Cisco supports the general use of Avaya IP Phones.
  • MAPD is EOL from June 2008.
  • Support for third-party ACD clients, SDKs, and interfaces integrated with ICM ends when the third-party ACD manufacturer ends mainstream support.
  • Ten-digit Agent extension and Agent ID are supported from ICM 9.0(3) and higher that has ACM 6.2 and higher; AES 6.2 and higher; and CMS R16 with RTA 6.0 pl: 13g.



Avaya CMS RTA Support Matrix

RTA Version ICM 10.5
4.1 No
4.5 No
4.6.1 No
4.6.2 No
4.6.4 No
4.6.5 No
4.7.3 No
4.8.1 No
5 No
5.0.5 No
5.0.5e No
6.0(x) Yes
6.0 Extended No



AES/CVLAN Server and CVLAN Client Support Matrix

AES (CVLAN) Server CVLAN Client Supported ICM 10.5 Notes
6.3 4.1.0
4.2.2
6.1
Yes



Avaya Communications Manager Support Matrix

ACD Version 1 ICM 10.5 Notes
ACM 2.2.2 No
ACM 3.02 No
ACM 3.1.0 No No support due to Avaya regression fix being provided with 3.1.1.
ACM 3.1.1.628.7
Patch 11761
No Supported with both AES 3.0 & AES 3.1 in CMS environments. No support in CMS-less with AES.
ACM 3.1.2 No Supported only in a CMS environment.
ACM 3.1.3 No Supports both CMS and CMS-Less configurations.
ACM 3.1.4 No
ACM 3.1.5 No
ACM 4.02 No
ACM 4.0.1 No
ACM 4.0.3 No
ACM 4.0.4 No
ACM 5.0 No
ACM 5.1 No
ACM 5.1.2 No
ACM 5.2 No
ACM 5.2.13 No
ACM 6.0 No
ACM 6.2 No
ACM 6.3 Yes

1Major ACD versions not listed here should be considered unsupported by Cisco.
2Avaya CM 4.x supports both MAPD and AES. However, MAPD is supported only up to ICM 7.2.4.
3Processor Ethernet is supported with AES 5.2.1 and ACM 5.2.1.


Avaya ARS Support Matrix

ACD Version1 ICM 10.5
4.0 No
4.0.1 No
4.0.3 No
4.0.4 No
5.0 No
5.1 No
5.1.2 No
5.2.1 No

1Major ACD versions not listed here should be considered unsupported by Cisco.

Avaya/Nortel

Caveats and special considerations apply with regard to support of this vendor's ACD/Switch types. Consider the following notes as you review the supported matrixes described below:

  • Cisco currently supports only select Succession platforms with Symposium. (See the following chart for details.)
  • SEI Lite integration is available for select ICM versions. The Cisco Automated Administrator for Symposium is required in order to integrate SEI Lite on ICM versions 5.0 and higher. (See the following chart for details.)
  • Cisco does not support more than one PG pair connected to a single Symposium server.
  • Customers who need to obtain the SCCS Toolkit must request this from Cisco. Please send an email to icm-nortelpg-sdk@cisco.com, and include the following information:
    • Customer name
    • Maintenance contract number
    • ICM version
    • PG version
    • Number of PGs


Avaya Aura Contact Center

AACC Version ICM 10.5
6.0 Yes
6.4  Yes
  • Note: The Automated Administrator for Symposium (AAS) feature is not supported with AACC 6.4.



Nortel SDK

ACD Version1 Notes
Nortel SDK 5.0 (with SCCS 5.0 and NCCM 6.0) From September 2008, no further support from Nortel will be provided for SCCS 5.0.
Nortel SDK 6.0 (with NCCM 6.0, NCCM 7.0, and AACC 6.0) HDX 6, RTD 6 must be installed on the PG. Note: SDKs are not integrated with ICM.


Note: NCCM (Nortel Contact Center Manager) earlier known as SCCS (Symposium), now renamed as AACC(Avaya Aura Contact Center).

CTI Support for ACD Types

ACD Vendor ACD Model CTI Server Protocol Support CTI OS Support
Alcatel 4400 ACD w/CSTA-2 Yes Yes
Aspect Contact Server Yes Yes
Avaya Avaya Communication Manager driven by Avaya S8300, S8400, S85xx, S87xx, and S88xx Servers Yes Yes
Cisco IPCC Yes Yes
Nortel DMS -100 Yes No
Nortel DMS -500 Yes No
Nortel SL - 100 No No
Nortel Symposium Yes Yes
Rockwell Galaxy No No
Aspect Spectrum w/ LAN Transaction Link Yes Yes
Aspect Spectrum w. X.25 Transaction Link Yes Yes


Remote Expert Mobile

For more information on Cisco Remote Expert Mobile, see the Cisco Contact Center Solutions and Unified Communications Manager Solution Configuration Guide for Remote Expert Mobile.

Apple iOS Device Support for REM

Apple iOS 7 and iOS 8 Devices Models
iPad iPad Air, iPad Air 2, iPad 2, iPad 3rd Generation, iPad 4th Generation
iPad Mini iPad Mini, iPad Mini with Retina Display, iPad Mini 3
iPhone iPhone 4S, iPhone 5, iPhone 5C, iPhone 5s, iPhone 6, iPhone 6 Plus, iPhone 7, iPhone 7 Plus
iPod Touch iPod Touch 5th Generation


Android Device Support for REM

Android Vendors Models
Samsung Galaxy S4, S4 Mini, S5, S5 Mini, S6, S7
Galaxy Note III (or newer)
Galaxy Tab S, Tab 4 (8.4" and 10.1")
Google Nexus 5, 6, 7, 9, and 10
LG G2, Optimus G3
Motorola Moto G
HTC One M7, M8, One Max
HP Slate 7, 8, and 10

Additional Notes:

  • Devices must be running Android version 4.1.2 or later (Jellybean, KitKat, Lollipop, Marshmallow, Nougat).
  • Not all devices have been tested, but the above are known to work.


Jabber System Requirements for REM Agents

System Requirement Jabber for Windows and Finesse Agent Desktop Jabber for Mac and Finesse Agent Desktop
Operating System
  • Microsoft Windows 7 SP1 or later: 32 and 64 bit
  • Microsoft Windows 8.x: 32 and 64 bit
  • Windows 10: 32-bit and 64-bit
  • Apple OS X Mountain Lion 10.8.1 or later
  • Apple OS X Mavericks 10.9 or later
  • Apple OS X Yosemite 10.10 or later
Installed RAM

4 GB

4GB

Free physical memory 2 GB 2 GB
Free disk space 1 GB 1 GB
CPU speed and type 4th Generation Intel Core i3 or later 1.6-GHz dual-core Intel Core i5 or later on the following hardware:
  • Mac Pro
  • MacBook Pro (including Retina Display models)
  • MacBook
  • MacBook Air
  • iMac
  • Mac mini
GPU DirectX 11 on Microsoft Windows 7 N/A
I/O ports USB 2.0 for USB camera and audio devices USB 2.0 for USB camera and audio devices
Screen resolution For Finesse clients, the minimum supported screen resolution is 1024x768. For Finesse clients, the minimum supported screen resolution is 1024x768.


Browser Support for REM Customers

Browser Supported Version Verified Against Plug-in Required Platform / Operating System
Google Chrome 33+ 47 No
  • Windows
  • OSX
  • Linux
  • Chromebook
Mozilla Firefox 28+ 40-43 No
  • Windows
  • OSX
  • Linux
Microsoft Internet Explorer 11 11 Yes Windows
Apple Safari 8+ 8.3 Yes OSX
Microsoft Edge 12+ 12 No Windows 10 Co-browsing only—no Voice & Video
Opera 28+ N/A No
  • Windows
  • OSX
  • Linux

Note: Mobile browsers are not supported.

Rating: 5.0/5 (9 votes cast)

Personal tools