Service Advertisement Framework Support in Unified Communications - System Test Configuration

From DocWiki

Jump to: navigation, search

Contents

Introduction

This page provides a reference configuration for Service Advertisement Framework (SAF) within the Cisco Unified Communications deployment. Service Advertisement Framework (SAF) support for Unified Communications includes support for Unified Communications Manager Express, Unified Communications Manager, Unified Survivable Remote Site Telephony, and IOS Voice Gateways. The configuration information is based primarily on testing performed on test beds having Service Advertisement Framework (SAF) configured during Cisco Unified Communications system releases.

The intended audience should be able to perform system-level configuration of Cisco Unified Communications components and deployments and be familiar with the Cisco Unified Communications family of products.

TIP: Use Service Advertisement Framework (Project Features Tested label) as a keyword to search for related test cases in System Test Results for IP Telephony.

This topic does not contain detailed step-by-step procedures; for detailed information about configuring Service Advertisement Framework, refer to the Unified Communications Manager documentation.

Design

Service Advertisement Framework (SAF) network service, a proprietary Cisco service facilitates dynamic provisioning of inter-call agent information. This framework allows networking applications to discover the existence, location and configuration of networked services within networks.

Cisco Unified Communications System 8.0(2) will be the first supported SAF application. This support includes Unified Communications Manager Express, Unified Communications Manager, Unified Survivable Remote Site Telephony and IOS Voice Gateways.

Let us see how Unified Communications Manager adopts SAF. By adopting the SAF network service, the call control discovery feature allows Cisco Unified Communications Manager to advertise itself along with other key attributes, such as directory number patterns that are configured in Cisco Unified Communications Manager Administration, so other call control entities that also use SAF network can use the advertised information to dynamically configure and adapt their routing behaviors; likewise, all entities that use SAF advertise the directory number patterns that they own along with other key information, so other remote call-control entities can learn the information and adapt the routing behavior of the call.

Figure 1: Propagating Reachability for Call Agents a in Unified Communications Environment.

SAF.jpg

The main SAF components include:

  • SAF client nodes
  • Forwarder nodes, and
  • Transparent nodes.

The SAF clients reside in the applications themselves, while the SAF forwarder resides in the Cisco IOS Software, and the two communicate in a client/server fashion.

For information on design considerations and guidelines for configuring SAF, see Cisco Unified Communications Manager 8.x Solution Reference Network Design (SRND).

For information on Service Advertisement Framework specific deployments and sites where system testing was performed, see Tested Deployments and Site Models for IP telephony.

Topologies

This section contains Service Advertisement Framework deployment scenario and call flows in system test environment.

Component Deployment

During Cisco Unified Communications 8.0(2) Release system testing, Service Advertisement Framework support was configured for Unified Communications Manager Express, Unified Communications Manager, and Unified Survivable Remote Site Telephony. The focus of system testing is centered on Call Control Discovery (CCD) and distribution of Directory Number ranges “To PSTN” prefixes.

The call control components Unified Communications Manager Express, Unified Communications Manager, and Unified Survivable Remote Site Telephony are known as SAF Clients are used in conjunction with IOS based SAF Forwarders.

Service Advertisement Framework tested in following deployment models.

Figure 2: Service Advertisement Framework System Test Deployment.

Toledo-SAF-deployment.jpg
  1. Site A consists of Unified CM cluster as SAF client and SAF forwarders are configured on two ISR 3845 routers. On the Unified CM cluster, SAF CCD service advertises its own DN Pattern and “To PSTN” reachability information to the SAF network.
    In addition it advertises the Remote SRST sites DN ranges and its corresponding 'To PSTN' prefix to SRST sites and other Unified CM cluster in the SAF network via SAF enabled SIP trunk. End-to-end RSVP profile is enabled on the SAF trunk in Site A.
  2. Site B consists of Unified CM cluster as SAF clients and SAF forwarders are configured on two ISR routers. On the Unified CM cluster, SAF CCD service advertises its own DN pattern and “To PSTN’ reachability information to the SAF network. End-to-end RSVP profile enabled on the SAF trunk in Site B.
  3. Site C consists of Unified CME cluster as SAF clients and SAF forwarder is configured on ISR 3825 router (in addition, Unified SIP Proxy module is configured on the router). Unified CME client in Site C advertises its own DN Pattern and “To PSTN” reachability information to other SAF clients in the SAF Network via SAF enabled SIP Trunk.
  4. Site D consist of previous version Unified Communications Manager which is unaware of SAF network.
  5. Remote Sites for Site A with Unified SRST as SAF clients.

The following functionalities were tested:

  • Service Advertisement Framework-CCD service: CUCM, CUCME
  • Service Advertisement Framework-CCD service: Automatic Alternate Routing for Unified SRST
  • Service Advertisement Framework with SIP Trunks
  • Service Advertisement Framework with End-to-end RSVP
  • Service Advertisement Framework to Service Advertisement Framework via Non-Service Advertisement Framework
  • Basic fail-over of Service Advertisement Framework clients (Unified CM) and SAF Forwarder

For more information on SAF tested functionality, see IP Telephony Test Results. Use Service Advertisement Framework (Project Features Tested label) as a keyword to search for related test cases.

Call Flow Diagram

Example call flows for Service Advertisement Framework:

SAF-call-flow.jpg

Configuration

This section provides the high-level tasks and related information for configuring Service Advertisement Framework. Default and recommended values specified in the product documentation were used during system testing to configure Service Advertisement Framework, except as noted.

Unified Communications Manager Configuration

This section provides information on how to configure the SAF forwarder and SAF Call Control Discovery (CCD) in Unified Communications Manager.

The following tables provide this information:

  • Configuration Tasks: List of high-level configuration tasks
  • System Test Specifics: System test variations from procedures and settings documented in the product documentation.
  • More Information: Links to product documentation for detailed configuration information related to the high-level tasks.

Table 1:Unified Communications Manager Configuration.

Configuration Tasks System Test Specifics More Information
1. Configure the Cisco IOS router as the SAF forwarder   See the documentation that supports your Cisco IOS router; for example, refer to the Cisco IOS Service Advertisement Framework Configuration Guide or the Cisco IOS Service Advertisement Framework Command Reference.
2. SAF Security Profile Configuration Settings   See SAF Security Profile Configuration Settings, Cisco Unified Communications Manager Features and Services Guide.
3. SAF Forwarder configuration   See SAF Forwarder Configuration Settings, Cisco Unified Communications Manager Features and Services Guide.
4. Configuring a SAF-Enabled Trunk   See Configuring a SAF-Enabled Trunk, Cisco Unified Communications Manager Features and Services Guide.
5. Hosted DN Patterns and Hosted DN Groups:
  • Hosted DN Group Configuration Settings
  • Hosted DN Pattern Configuration Settings
  See Hosted DN Group Configuration Settings and Hosted DN Pattern Configuration Settings, Cisco Unified Communications Manager Features and Services Guide.
6. CCD Advertising Service Configuration Settings   See CCD Advertising Service Configuration Settings, Cisco Unified Communications Manager Features and Services Guide.
7. Partition Configuration Settings for Call Control Discovery   See Partition Configuration Settings for Call Control Discovery, Cisco Unified Communications Manager Features and Services Guide.
8. Partition CCD Requesting Service Configuration Settings   See CCD Requesting Service Configuration Settings, Cisco Unified Communications Manager Features and Services Guide.
9. Blocked Learned Pattern Configuration Settings   See Blocked Learned Pattern Configuration Settings, Cisco Unified Communications Manager Features and Services Guide.

Unified CME Configuration

interface Loopback0
description Binding SIP
ip address 10.10.1.5 255.255.255.255
ip rsvp bandwidth

router eigrp 8
network 8.8.8.1 0.0.0.0
network 10.10.1.5 0.0.0.0
network 10.10.8.0 0.0.0.63
network 10.10.8.64 0.0.0.63

router eigrp VOICE-SERVICE
 !
service-family ipv4 autonomous-system 333
 !
topology base
exit-sf-topology
neighbor 3.3.3.4 Loopback0 remote 100
neighbor 3.3.3.3 Loopback0 remote 100
neighbor 10.10.1.178 Loopback0 remote 100
neighbor 10.10.1.231 Loopback0 remote 100
exit-service-family


voice service saf
profile trunk-route 1
session protocol sip interface Loopback0 transport tcp port 5060
 !
profile dn-block 1
pattern 1 type extension 2XXX
 !
profile callcontrol 2
dn-service
site-code 835 extension-length 7
trunk-route 1
dn-block 1
 !
 !
call
timer aar-ageout 15
 !
channel 1 vrouter VOICE-SERVICE asystem 333
subscribe callcontrol wildcarded
publish callcontrol 2

Unified SRST Configuration

router eigrp VOICE-SERVICE
 !
service-family ipv4 autonomous-system 333
 !
sf-interface FastEthernet0/1
shutdown
exit-sf-interface
 !
topology base
exit-sf-topology
neighbor 7.7.7.7 Loopback1 remote 100
neighbor 7.7.7.212 Loopback1 remote 100
neighbor 7.7.7.8 Loopback1 remote 100
neighbor 3.3.3.4 Loopback1 remote 100
neighbor 3.3.3.3 Loopback1 remote 100
neighbor 5.5.5.5 Loopback1 remote 100
exit-service-family


voice service saf
call
timer aar-ageout 1440
channel 1 vrouter VOICE-SERVICE asystem 333
subscribe callcontrol wildcarded

SAF –Forwarder Configuration

service-family external-client listen ipv4 5050
external-client cdg basename
username safuser
password gbindia123!
keepalive 60000

router eigrp VOICE-SERVICE
service-family ipv4 autonomous-system 333
sf-interface GigabitEthernet0/1
bandwidth-percent 75
exit-sf-interface
topology base
external-client cdg
exit-sf-topology
neighbor 3.3.3.3 Loopback1 remote 100
neighbor 7.7.7.202 Loopback1 remote 100
neighbor 7.7.7.212 Loopback1 remote 100
neighbor 5.5.5.5 Loopback1 remote 100
neighbor 7.7.7.8 Loopback1 remote 100
neighbor 3.3.3.4 Loopback1 remote 100
exit-service-family

Related Documentation

For information on installing, configuring, managing, and using Cisco Unified Communications Manager features, see Cisco Unified Communications Manager Features and Services Guide

For information on the results obtained from the system testing, see IP Telephony Test Results

For information on configuring the security components, see Security System Configurations

Rating: 0.0/5 (0 votes cast)

Personal tools