Cisco Unified Survivable Remote Site Telephony Configuration

From DocWiki

Jump to: navigation, search
Cisco Unified Survivable Remote Site Telephony Configuration

This topic provides a reference configuration for Cisco Unified Survivable Remote Site Telephony (SRST) within a Cisco Unified Communications deployment. This topic does not contain detailed step-by-step procedures; instead, for or detailed information about installing, configuring, and administering SRST, refer to the Cisco Emergency Responder documentation listed in Related Documentation section.

Reference Configuration

The system-wide testing of IP telephony functionality for Cisco Unified Communications included for Cisco Unified Survivable Remote Site Telephony (SRST). For general information about the tested functionality in Cisco Unified Communications , see the System Release Notes.

Network Topologies

During Cisco Unified Communications testing, this component was installed and tested in the following site models:

  • HNL and DFW for load testing
  • MAN and ABI for features and functionality testing

For more information on these site models, see Tested Deployments and Site Models.

Configuration Details

For complete details on how a representative SRST was configured during Cisco Unified Communications testing, see Configuration Command Files.

For detailed information about installing, configuring, and administering Cisco Emergency Responder, refer to the documentation at [http://www.cisco.com/en/US/products/sw/voicesw/ps2169/products_documentation_roadmap09186a008018912f.html

This chapter includes the following sections:

  • Cisco Unified Communications Manager Configuration for Unified SRST
  • Unified SRST Configuration Files

Cisco Unified Communications Manager Configuration for Unified SRST

Unified SRST was configured in Cisco Communications Manager Administration as part of the device pool for phones at remote sites. First, the SRST reference for each remote site was configured. Then SRST references were associated with device pools. In this way, when a phone downloads its configuration, it receives the following information:

  • Primary Unified Communications Manager server
  • Secondary and tertiary Unified Communications Manager servers, if applicable
  • SRST Unified Communications Manager server

Table 1 provides an example of how remote site SRST references were configured in the SRST Reference Configuration page for the following SRST gateways:

  • HNL1-SRST and HNL2-SRST in sites HNL1 and HNL2 that are normally managed by a Unified Communications Manager cluster split across the San Jose (SJC) and Rockford (RFD) sites.

To access the SRST Reference Configuration page, choose System > SRS'T' from the Cisco Communications Manager Administration application.

  • Unified Communications Manager SRST Reference Configuration  
Field Settings for HNL1-SRST Settings for HNL2-SRST
Name HNL1-SRST HNL2-SRST
Port 2000 2000
IP Address 10.9.28.2 10.9.38.1
SIP Network/IP Address<ref>This address must be configured for Unified SRST servers supporting SIP phones. Not required for H.323 or MGCP environments.</ref> 10.9.28.2 blank
SIP Port 5060 5060
SRST Certificate Provider Port 2445 2445
Is SRST Secure? No (unchecked) No (unchecked)

Table 2 provides an example of how the SRST references shown in the previous table were associated with device pools for the remote site. This configuration was made in the Device Pool Configuration page. You access this page by choosing System > Device Pool from the Cisco Communications Manager Administration application.

  • Unified Communications Manager Device Pool Configuration (continued)
Field Settings for DP_CM1_2_HNL1 Settings for DP_CM1_2_HNL2
Device Pool Name DP_CM1_2_HNL1 DP_CM1_2_HNL2
Cisco Communications Manager Group CM1_2 CM1_2
Date/Time Group HNL HNL
Region HNL1-Local HNL2-Local
Softkey Template Standard Features - All Standard Feature
SRST Reference HNL1-SRST HNL2-SRST
Calling Search Space for Auto-registration <None> <None>
Media Resource Group List MRGL-HNL1-ALLhw MRGL-HNL2-ALLhw
Network Hold MOH Audio Source 1-SampleAudioSource <None>
User Hold MOH Audio Source 1-SampleAudioSource <None>
Network Locale <None> <None>
User Locale <None> <None>
Connection Monitor Duration 120 blank
MLPP Indication Default Default
MLPP Preemption Default Default
MLPP Domain <None> DP_CM1_2_HNL1

Unified SRST Configuration Files

An Unified SRST configuration file is a standard H.323 or MGCP gateway configuration file with additional commands that allow a site to continue to function without connectivity to the centralized Unified Communications Manager.

Unified SRST Configuration for a H.323 Gateway

This section shows a configuration file that includes the following:

  • Configuration for a fully functional H.323 gateway (HNL1-SRST) when the centralized Unified Communications Manager is reachable
  • Commands to make the router function as in a stand-alone site if connectivity to the centralized Unified Communications Manager is lost

!

version 12.4

!

hostname HNL1-SRST-2851

!

boot-start-marker

boot system flash flash:c2800nm-ipvoice_ivs-mz.124-13.13.T2

boot-end-marker

!

no logging buffered

enable secret 5 $1$lWM6$Fw1CJdA2hjEN6k/pTF0Y00

!

no aaa new-model

network-clock-participate wic 0

no network-clock-participate wic 1

ip cef

!

ip domain name cisco.com

ip name-server 10.9.12.4

multilink bundle-name authenticated

!

isdn switch-type primary-ni

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice dsp release early

!

voice service voip

h323

call start slow

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

voice class h323 1

h225 timeout tcp establish 3

!

archive

log config

hidekeys

!

controller T1 0/0/0

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-24

description To AS5400-PSTN T1 6/0

!

controller T1 0/0/1

framing esf

linecode b8zs

!

controller T1 0/1/0

framing esf

linecode b8zs

!

controller T1 0/1/1

framing esf

linecode b8zs

!

interface GigabitEthernet0/0

description HLN1-3524 PORT 0/7

ip address 10.9.28.2 255.255.255.0

duplex auto

speed auto

ip rsvp bandwidth 2000

ip rsvp resource-provider none

!

interface GigabitEthernet0/1

ip address 10.3.2.153 255.255.254.0

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Service-Engine1/0

ip unnumbered GigabitEthernet0/0

service-module ip address 10.9.28.4 255.255.255.0

service-module ip default-gateway 10.9.28.2

!

ip route 0.0.0.0 0.0.0.0 10.9.28.1

ip route 10.9.28.4 255.255.255.255 Service-Engine1/0

!

ip http server

ip http authentication local

ip http timeout-policy idle 600 life 86400 requests 10000

!

snmp-server community public RO

snmp-server community private RW

snmp-server system-shutdown

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps tty

snmp-server enable traps frame-relay multilink bundle-mismatch

snmp-server host 10.9.12.21 version2

snmp-server host 10.9.22.34 version2

!

control-plane

!

voice-port 0/0/0:23

!

voice-port 2/0/0

shutdown

!

voice-port 2/0/1

shutdown

!

voice-port 2/0/2

shutdown

!

voice-port 2/0/3

!

voice-port 2/0/4

!

voice-port 2/0/5

!

voice-port 2/0/6

!

voice-port 2/0/7

!

sccp local GigabitEthernet0/0

sccp ccm 10.9.20.3 identifier 2 version 5.0.1

sccp ccm 10.9.10.5 identifier 1 version 5.0.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 3 register MTP-SOFT-HNL1

associate profile 1 register CFB0013c47bbcf8

associate profile 2 register MTP0013c47bbcf8

!

dspfarm profile 2 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729br8

codec g729r8

codec pass-through

rsvp

maximum sessions 6

associate application SCCP

!

dspfarm profile 1 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP

!

dspfarm profile 3 mtp

codec pass-through

codec g711ulaw

rsvp

maximum sessions software 10

associate application SCCP

shutdown

!

!

dial-peer voice 1 pots

description To AS5400-PSTN T1 6/0

destination-pattern .T

progress_ind setup enable 3

direct-inward-dial

port 0/0/0:23

forward-digits all

!

dial-peer voice 100 voip

destination-pattern 20335.....

voice-class codec 1

session target ipv4:10.9.10.5

incoming called-number 20335.....

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

no vad

!

dial-peer voice 101 voip

preference 1

destination-pattern 20335.....

voice-class codec 1

voice-class h323 1

session target ipv4:10.9.20.3

incoming called-number 20335.....

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

no vad

!

dial-peer voice 3 pots

shutdown

destination-pattern .T

incoming called-number .T

no digit-strip

direct-inward-dial

port 0/0/0:23

!

gatekeeper

shutdown

!

call-manager-fallback

video

max-conferences 8 gain -6

transfer-system full-blind

ip source-address 10.9.28.2 port 2000

max-ephones 10

max-dn 10

dialplan-pattern 1 20335..... extension-length 5

voicemail 22100

call-forward pattern .T

call-forward busy 22100

call-forward noan 22100 timeout 12

!

!

line con 0

exec-timeout 0 0

line aux 0

line 66

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120

line vty 0 4

exec-timeout 60 0

password 7 0507070D

login

line vty 5 15

exec-timeout 60 0

password 7 0507070D

login

!

scheduler allocate 20000 1000

!

end

Unified SRST Configuration for a MGCP Gateway

This section shows a configuration file that includes the following:

  • Configuration for a fully functional MGCP gateway (HNL2-SRST) when the centralized Unified Communications Manager is reachable
  • Commands to make the router function as in a stand-alone site if connectivity to the centralized Unified Communications Manager is lost

The files include notes that explain items specific to an Unified SRST configuration.

version 12.4

!

hostname HNL2-SRST-2691

!

boot-start-marker

boot system flash slot0:c2691-ipvoicek9-mz.124-13.13.T2

boot system flash flash:c2691-ipvoicek9-mz.124-13.9.PI6a

boot-end-marker

!

card type t1 1 1

enable secret 5 $1$LAOU$x0UV0A3HIuEdJWT.sXx6l.

!

no aaa new-model

clock timezone HST -10

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.9.38.1 10.9.38.247

ip dhcp excluded-address 10.9.39.1 10.9.39.247

!

ip dhcp pool VOICE

network 10.9.38.0 255.255.255.0

option 150 ip 10.9.14.4

default-router 10.9.38.1

dns-server 10.9.12.4

domain-name cisco.com

!

ip dhcp pool DATA

network 10.9.39.0 255.255.255.0

option 150 ip 10.9.14.4

default-router 10.9.39.1

domain-name cisco.com

dns-server 10.9.12.4

!

ip domain name cisco.com

ip name-server 10.9.12.4

multilink bundle-name authenticated

isdn switch-type primary-ni

voice-card 1

dspfarm

dsp services dspfarm

!

no voice call carrier capacity active

!

voice service voip

redirect ip2ip

sip

registrar server

redirect contact order best-match

!

voice register pool 1

id network 10.9.28.0 mask 255.255.255.0

application sip.app

preference 2

proxy 10.9.10.5 preference 1 monitor probe icmp-ping 10.9.20.3

!

application

global

service alternate DEFAULT

!

archive

log config

hidekeys

!

!

controller T1 0/0

framing esf

linecode b8zs

cablelength short 133

channel-group 0 timeslots 1-24

description To SJC-RFD-WAN router T1 1/2

!

controller T1 0/1

framing sf

linecode ami

!

controller T1 1/0

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-24 service mgcp

!

controller T1 1/1

framing sf

linecode ami

!

ip rcmd rcp-enable

ip rcmd remote-host cwuser 10.9.22.34 cwuser enable

!

translation-rule 10

Rule 1 ^2 1408462

Rule 2 ^5 1210525

!

translation-rule 11

Rule 1 ^. 40423

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.38

encapsulation dot1Q 38

ip address 10.9.38.1 255.255.255.0

!

interface FastEthernet0/0.39

encapsulation dot1Q 39

ip address 10.9.39.1 255.255.255.0

!

interface Serial0/0:0

no ip address

encapsulation frame-relay

no clns route-cache

ip rsvp bandwidth 800

ip rsvp resource-provider none

!

interface Serial0/0:0.1 point-to-point

description To SJC-RFD-WAN router T1 1/2

ip address 10.3.181.162 255.255.255.252

frame-relay interface-dlci 103

ip rsvp bandwidth 800

ip rsvp resource-provider none

!

interface FastEthernet0/1

description ADMIN-4506 Fe2/23

ip address 10.3.2.105 255.255.254.0

speed 100

full-duplex

!

interface Serial1/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

router ospf 1

log-adjacency-changes

network 10.3.181.160 0.0.0.3 area 38

network 10.9.38.0 0.0.0.255 area 38

network 10.9.39.0 0.0.0.255 area 38

!

!

no ip http server

no ip http secure-server

!

ip sla responder

no logging trap

snmp-server community public RO

snmp-server community private RW

snmp-server system-shutdown

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps tty

snmp-server enable traps frame-relay multilink bundle-mismatch

snmp-server host 10.9.12.21 version2

snmp-server host 10.9.22.34 version2

!

control-plane

!

call fallback active

!

voice-port 1/0:23

!

ccm-manager fallback-mgcp

ccm-manager redundant-host sjc-rfd-sub-2

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.9.14.4

ccm-manager config

!

mgcp

mgcp call-agent sjc-rfd-sub-1 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/0.38

mgcp bind media source-interface FastEthernet0/0.38

!

mgcp profile default

!

sccp local FastEthernet0/0.38

sccp ccm 10.9.10.5 identifier 1 version 4.1

sccp ccm 10.9.20.3 identifier 2 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 1 register CFB0009e837d760

associate profile 2 register MTP0009e837d760

associate profile 3 register MTP-SOFT-HNL2

!

dspfarm profile 2 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec pass-through

rsvp

maximum sessions 10

associate application SCCP

!

dspfarm profile 1 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP

!

dspfarm profile 3 mtp

codec pass-through

codec g711ulaw

rsvp

maximum sessions software 10

associate application SCCP

shutdown

!

dial-peer cor custom

!

dial-peer voice 10 pots

description connection to PSTN

destination-pattern 92.T

incoming called-number .

direct-inward-dial

port 1/0:23

!

dial-peer voice 11 pots

description connection to SJC PSTN

destination-pattern 2....

translate-outgoing called 10

incoming called-number .

direct-inward-dial

port 1/0:23

!

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

ip source-address 10.9.38.1 port 2000

max-ephones 10

max-dn 10

dialplan-pattern 1 20441..... extension-length 5

transfer-pattern .T

voicemail 22100

call-forward pattern .T

call-forward noan 9214084622100 timeout 5

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

exec-timeout 0 0

password 7 060A0E23

login

!

ntp clock-period 17180549

ntp server 10.3.181.161

!

end

Related Documentation

For related information about SRST, see the documents listed in Table 3.

  • SRST Documentation  
Document URL
General Cisco Unified Survivable Remote Site Telephony [http://www.cisco.com/en/US/products/sw/voicesw/ps2169/products_documentation_roadmap09186a008018912f.html
Cisco Unified SRST System Administrator Guide [http://www.cisco.com/en/US/products/sw/voicesw/ps2169/products_installation_and_configuration_guides_list.html
Configuring a Secure Survivable Remote Site Telephony (SRST) Reference [http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/security/7_0_1/secugd/secugd-cm.pdf

Rating: 0.0/5 (0 votes cast)

Personal tools