Cisco Unified Presence, Release 7.x -- How to View Log Files on the Perfmon Log Viewer and Microsoft Performance Tool

From DocWiki

Jump to: navigation, search

Main page: Cisco Unified Presence, Release 7.x

Contents

Previous Topic


Perfmon Log Viewer

The performance log viewer displays a chart with the data from the selected counters. The bottom pane displays the selected counters, a color legend for those counters, display option, mean value, minimum value, and the maximum value.


Table 1: Performance Log Viewer describes the functions of different buttons that are available on the Performance Log Viewer.

Table 1: Performance Log Viewer
Button Function

Select Counters

Allows you to add counters that you want to display in the performance log viewer. If you do not want to display a counter, uncheck the Display column next to the counter.

Reset View

Resets the performance log viewer to the initial default view.

Save Downloaded File

Allows you to save the log file to your local computer.



Viewing Log Files on the Perfmon Log Viewer

The Performance Log Viewer displays data for counters from perfmon CSV log files in a graphical format. You can use the performance log viewer to display data from the local perfmon logs that you collected, or you can display the data from the Alert Manager and Collector (AMC) perfmon logs and Realtime Information Server Data Collection (RISDC) perfmon logs.


Before You Begin

The local perfmon logs consist of data from counters that you select and store locally on your computer.


Procedure

1. Perform one of the following actions:

  • On the Quick Launch Channel:
    • Click System.
    • In the tree hierarchy, double-click Performance.
    • Click the Performance Log Viewer icon.
  • Select System > Performance > Open Performance Log Viewer.

2. Select the type of perfmon logs that you want to view:

  • For AMC or RisDC Perfmon Logs, perform the following steps:
    • Click on either AMC Perfmon Logs or Perfmon Logs and select a node from the Select a node list box.
    • Click Open.
    • Select the file and Click Open File.
    • Check the counters that you want to display.
    • Click OK.
  • For locally stored data, perform the following actions:
    • Click Local Perfmon Logs.
    • Click Open.
    • Browse to the file directory.
    • Select the file that you are interested in viewing or enter the file name in the filename field.
    • Click Open.

3. Select the counters that you want to display.

4. Click OK.


Troubleshooting Tips
  • The Real-Time Monitoring Tool (RTMT) saves the perfmon CSV log files in the log folder in the.jrtmt directory under the user home directory. In Windows, the path specifies D:\Documents and Settings\userA\.jrtmt\log, or in Linux, the path specifies /users/home/.jrtmt/log
  • When you enable AMC and RISDC perfmon logs, Cisco Unified Presence collects information for the system in logs that are written on the Cisco Unified Presence. You can enable or disable AMC and RISDC perfmon logs on Cisco Unified Presence Administration by choosing System > Service Management. By default, AMC perfmon logging is enabled and RISDC perfmon logging is disabled.
  • The RISDC perfmon logging is also known as Troubleshooting Perfmon Data logging. When you enable RISDC perfmon logging, the server collects data that are used to troubleshoot problems. Because Cisco Unified Presence collects a large amount of data in a short period of time, you should limit the time that RISDC perfmon data logging (troubleshooting perfmon data logging) is enabled.
  • You can order each column by clicking on a column heading. The first time that you click on a column heading, the records display in ascending order. A small triangle pointing up indicates ascending order. If you click the column heading again, the records display in descending order. A small triangle pointing down indicates descending order. If you click the column heading one more time, the records displays in the unsorted state.


Related Topics


Zooming In and Out in the Performance Log Viewer

The Performance Log viewer includes a zoom feature that allows you to zoom in on and out on an area in the chart.


Procedure
  1. Perform one of the following actions:
    • On the Quick Launch Channel:
      • Click System.
      • In the tree hierarchy, double-click Performance.
      • Click the Performance icon.
    • Select System > Performance > Open Performance Monitoring.
  2. Click the name of the server where the counter is located.
    The tree hierarchy expands and displays all the perfmon objects for the node.
  3. Double-click the performance counter you want to monitor.
  4. Perform one of the following actions:
If you want to: Action

Zoom in on an area in the chart

  1. Click and drag the left mouse button over the area of the chart in which you are interested.
  2. Release the left mouse button when you have the selected area.

Reset the chart to the initial default view

  1. Perform one of the following actions:
  • Click Reset View.
  • Right-mouse click the chart and select Reset.


Related Topics


Viewing the Perfmon Log Files with the Microsoft Performance Tool

Procedure
  1. Select Start > Settings > Control Panel > Administrative Tools > Performance.
  2. Perform the following actions in the application window:
    1. Click the right mouse button.
    2. Select Properties.
  3. Click the Source tab in the System Monitor Properties dialog box.
  4. Browse to the directory where you downloaded the perfmon log file and select the perfmon csv file. The log file includes the following naming convention: PerfMon_<node>_<month>_<day>_<year>_<hour>_<minute>.csv; for example, PerfMon_172.19.240.80_06_15_2005_11_25.csv.
  5. Click Apply.
  6. Click the Time Range button. To specify the time range in the perfmon log file that you want to view, drag the bar to the appropriate starting and ending times.
  7. To open the Add Counters dialog box, click the Data tab and click Add.
  8. Select the perfmon object from the Performance Object list box. If an object has multiple instances, you may select All instances or select only the instances that you are interested in viewing.
  9. You can select All Counters or select only the counters that you are interested in viewing.
  10. Click Add to add the selected counters.
  11. Click Close when you finish selecting counters.


Related Topics


Viewing Log Files on the SysLog Viewer

Table 2: Syslog Viewer Buttons describes the functions in syslog message

Table 2: Syslog Viewer Buttons
Button Function

Refresh

Updates the contents of the current log on the syslog viewer.

Tip: You can enable the syslog viewer to automatically update the syslog messages by checking the Auto Refresh button.

Clear

Clears the display of the current log.

Filter

Limits the messages that displayed base on the set of options that you select.

Clear Filter

Removes the filter that limits the type of messages that display.

Find

Allows you to search for a particular string in the current log.

Save

Saves the currently selected log on your PC

Procedure

1. Perform one of the following actions:

  • In the Quick Launch Channel, click the Tools tab
    • Click SysLog Viewer.
    • Click the SysLog Viewer icon.
  • Select System > Tools > SysLog Viewer> Open SysLog Viewer.

2. Select the server where the logs that you want to view are stored from the Select a Node list box.

3. Click the tab for the logs that you want to view.

4. Double-click the log icon to list the file names in the same window.

5. Click the file name to view the contents of the file at the bottom of the window.

6. Click the entry that you want to view.

7. Double-click the syslog message to view the complete syslog message. You can also use the buttons that are described in Table 2: Syslog Viewer Buttons to view the syslog messages.


Troubleshooting Tips
  • To make a column larger or smaller, drag the arrow that displays when your mouse hovers between two column headings.
  • You can order the messages by clicking on a column heading. The first time that you click on a column heading, the records display in ascending order. A small triangle pointing up indicates ascending order. If you click the column heading again, the records display in descending order. A small triangle pointing down indicates descending order. If you click the column heading one more time, the records displays in the unsorted state
  • You can filter the results by choosing an option in the Filter By list box. To remove the filter, click Clear Filter. All logs display after you clear the filter.
Related Topics

Rating: 0.0/5 (0 votes cast)

Personal tools