Cisco Unified Border Element SIP Trunk Configuration Example

From DocWiki

Jump to: navigation, search

Contents

Overview

This article provides information on configuring a SIP trunk from Cisco Unified Communications Manager to an IP-IP Gateway or Cisco Unified Border Element.

IP-IP Gateway SIP Trunk Configuration 01.png

In this configuration example, San Jose (SJC) site is part of a very large campus which has a Cisco Unified Communications Manager cluster over an IP WAN. Atlanta (ATL) is small campus SIP site that has Cisco Unified Communications Manager Express cluster. ATL site communicates with Cisco Unified Communications Manager cluster in the SJC site using a SIP trunk through an IP-to-IP gateway that is deployed on ATL site.

Configuration Details

First configure the Cisco 3745s IP address, mask and default gateway. To this configuration add authentication statements. IP routing must be enabled on voice gateways and logging parameters also need to be defined.

Here is an example configuration in which FastEthernet interface 0/0 is configured to connect to the IP network through which SIP proxy is reachable. In the following example, H.323 VoIP gateway functions are enabled on the Ethernet 0/0 interface. The h323-gateway voip bind srcaddr command is used bind H.323 signaling to the IP address of the interface. The designated source IP address is the same as the IP address assigned to the interface.

interface FastEthernet0/0
  ip address 10.3.80.5 255.255.255.0
  duplex auto
  speed auto
  h323-gateway voip interface
  h323-gateway voip id ipip-gk ipaddr 10.3.70.99 1719
  h323-gateway voip h323-id ip-ip-gw
  h323-gateway voip tech-prefix 1#
  h323-gateway voip bind srcaddr 10.3.80.5

Configuring Voice-Card for DSPFarm

This section provides information on configuring voice-card for DSPFarm. This enables DSP farming allowing DSP resources to register to Cisco Unified CM as MTP, CFB or Transcoder devices.

voice-card 3
  dspfarm

Enabling Cisco Express Forwarding

To enable CEF, use the following command in global configuration mode:

ip cef

Enabling Calls in VoIP Network

From the voice service voip configuration, enable calls between endpoints in the VoIP network. This configuration allows all call combination types of connections between H323/SIP protocols. It enables midcall media re-negotiation for supplementary services and during supplementary services operation, ringback to be generated locally.

voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 h323
  emptycapability
  h225 id-passthru 
  h225 connect-passthru 
  h245 passthru tcsnonstd-passthru

Defining codecs

Some sites may use a single codec while others may find it advantageous to define a list of available codecs in the order in which they should be tried during call setup. If you choose to implement a list you accomplish this task using the voice class codec command. Note that this only defines the list of available codecs. Once defined the list must be applied to each applicable dial-peer using the voice-class codec command. The dial-peer command is described later in this document.

This command enables multiple codec support and performs codec filtering

voice class codec 1
 codec preference 3 g711ulaw

voice class codec 2
 codec preference 2 g729r8
 codec preference 3 g711ulaw

voice class codec 3
 codec preference 1 g729br8
 codec preference 2 g729r8

Configuring the WAN interface

To configure a WAN circuit in this environment, first define the physical layer (T1 specific) parameters.

controller T1 0/0
 framing sf
 linecode ami

controller T1 3/0
 framing sf
 linecode ami

controller T1 3/1
 framing sf
 linecode ami

Configuring dial-peers

The dial-peer is where forwarding decisions are made based upon destination-pattern pattern matching. If more than one peer is matched the preference parameter determines the order in which the peers are tried. The dial-peer statement is also where translation-rules and codec decisions are made.

In this example you will see that the list of supported codecs is specified in the voice-class codec statement described above.

dial-peer voice 1 voip
 description cme-2691
 destination-pattern 404328....
 session protocol sipv2
 session target ipv4:10.3.81.2
 session transport udp
 codec g711ulaw

dial-peer voice 2 voip
 description cme-3725
 destination-pattern 404327....
 session protocol sipv2
 session target ipv4:10.3.80.2
 session transport udp
 dtmf-relay sip-notify
 codec g711ulaw
...
...

SNMP monitoring and traps

This section provides information on configuring SNMP monitoring and trap.

snmp-server community public RO
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 

Configuring DSP resources

Commands to configure DSP resources Cisco Unified Communications Manager:

sccp local FastEthernet0/0
sccp ccm 10.3.24.4 identifier 2 version 5.0.1 
sccp ccm 10.3.24.3 identifier 1 version 5.0.1 
sccp

sccp ccm group 1
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 10 register ipip-gw
 associate profile 11 register ipip-gw
 associate profile 12 register ipip-gw

dspfarm profile 10 transcode  
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 codec g729r8
 maximum sessions 60
 associate application SCCP

dspfarm profile 11 conference  
 description conference bridge
 codec g729br8
 codec g729r8
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 maximum sessions 10
 associate application SCCP

dspfarm profile 12 mtp
 codec g711ulaw
 codec pass-through
 maximum sessions software 10
 associate application SCCP

Related show Commands

This section provides information you can use to confirm your configuration is working properly:

show interfaces ''interface-name''
show ccm-manager
show dial-peer voice

show running-config

Building configuration...

Current configuration : 4720 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ATL-IPIPGW
!
boot-start-marker
boot system flash flash:c3745-adventerprisek9_ivs-mz.124-060807.2007-06-08
boot system flash flash:c3745-adventerprisek9_ivs-mz.124-13.13.T5
boot-end-marker
!
enable password lab
!
no aaa new-model
no network-clock-participate slot 2 
no network-clock-participate slot 3 
no network-clock-participate wic 0 
voice-card 3
 dspfarm
!
ip cef
!
no ip domain lookup
!
multilink bundle-name authenticated
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 h323
  emptycapability
  h225 id-passthru 
  h225 connect-passthru 
  h245 passthru tcsnonstd-passthru
!
voice class codec 1
 codec preference 3 g711ulaw
!
voice class codec 2
 codec preference 2 g729r8
 codec preference 3 g711ulaw
!
voice class codec 3
 codec preference 1 g729br8
 codec preference 2 g729r8
!
archive
 log config
  hidekeys
!
controller T1 0/0
 framing sf
 linecode ami
!
controller T1 3/0
 framing sf
 linecode ami
!
controller T1 3/1
 framing sf
 linecode ami
!
ip rcmd rcp-enable
ip rcmd remote-host cwuser 10.9.22.34 cwuser enable
!
interface FastEthernet0/0
 ip address 10.3.80.5 255.255.255.0
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip id ipip-gk ipaddr 10.3.70.99 1719
 h323-gateway voip h323-id ip-ip-gw
 h323-gateway voip tech-prefix 1#
 h323-gateway voip bind srcaddr 10.3.80.5
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 10.3.80.1
!
ip http server
no ip http secure-server
!
snmp-server community public RO
snmp-server community private RW
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server host 10.9.12.21 version2 
snmp-server host 10.9.22.34 version2 
!
tftp-server flash:c3745-ipvoice_ivs-mz.124-2.9.PI2a
tftp-server flash:c3745-ipvoice_ivs-mz.124-4.7.PI3a
!
control-plane
!
sccp local FastEthernet0/0
sccp ccm 10.3.24.4 identifier 2 version 5.0.1 
sccp ccm 10.3.24.3 identifier 1 version 5.0.1 
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 10 register ipip-gw
 associate profile 11 register ipip-gw
 associate profile 12 register ipip-gw
!
dspfarm profile 10 transcode  
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 codec g729r8
 maximum sessions 60
 associate application SCCP
!
dspfarm profile 11 conference  
 description conference bridge
 codec g729br8
 codec g729r8
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 maximum sessions 10
 associate application SCCP
!
dspfarm profile 12 mtp
 codec g711ulaw
 codec pass-through
 maximum sessions software 10
 associate application SCCP
!
dial-peer voice 1 voip
 description cme-2691
 destination-pattern 404328....
 session protocol sipv2
 session target ipv4:10.3.81.2
 session transport udp
 codec g711ulaw
!
dial-peer voice 2 voip
 description cme-3725
 destination-pattern 404327....
 session protocol sipv2
 session target ipv4:10.3.80.2
 session transport udp
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 3 voip
 description cme-3845
 destination-pattern 404329....
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.3.82.2
 session transport tcp
 incoming called-number 404329....
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 4 voip
 description cme-2611
 destination-pattern 404330....
 session protocol sipv2
 session target ipv4:10.3.83.2
 session transport udp
!
dial-peer voice 5 voip
 description cme-1760
 destination-pattern 404331....
 session protocol sipv2
 session target ipv4:10.3.84.2
 session transport udp
!
dial-peer voice 101 voip
 destination-pattern 21052.....
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.9.20.3
 session transport tcp
 incoming called-number 21052.....
 dtmf-relay rtp-nte sip-kpml sip-notify
!
dial-peer voice 100 voip
 destination-pattern 40846.....
 voice-class codec 1
 session protocol sipv2
 session target ipv4:10.9.10.5
 session transport tcp
 incoming called-number 40846.....
 dtmf-relay rtp-nte sip-kpml sip-notify
!
dial-peer voice 6 voip
 destination-pattern 910555....
 session protocol sipv2
 session target ipv4:10.3.90.6
 incoming called-number 910555....
 codec g711ulaw
!
dial-peer voice 7 voip
 destination-pattern 97678.....
 session protocol sipv2
 session target ipv4:10.3.24.3
 incoming called-number 97678.....
 dtmf-relay rtp-nte
 codec g711ulaw
!
gateway 
 timer receive-rtp 1200
!
gatekeeper
 shutdown
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 password lab
 login
!
webvpn cef
!
end

Related Information

Cisco Unified Border Element (formerly know as Cisco Multiservice IP-to-IP Gateway)
http://www.cisco.com/en/US/products/sw/iosswrel/ ps1839/products_feature_guide_book09186a00801 e89e3.html

Rating: 1.3/5 (3 votes cast)

Personal tools