Cisco NX-OS/IOS Port-Channel Comparison

From DocWiki

Jump to: navigation, search

Objective

This tech note outlines the main differences in Port-Channel support between Cisco® NX-OS Software and Cisco IOS® Software. Sample configurations are included for Cisco NX-OS and Cisco IOS Software for some common features to demonstrate the similarities and differences. Please refer to the NX-OS documentation on Cisco.com for a complete list of supported features.


Port-Channel Overview

Port-Channels provide a mechanism for aggregating multiple physical Ethernet links into a single logical Ethernet link. Port-Channels are typically used to increase availability and bandwidth, while simplifying the network topology. Port-Channels can be configured using Static Mode (no protocol) or the Link Access Control Protocol (LaCP) defined in IEEE 802.3ad for dynamic negotiations and keep-alive detection for failover.


Important Cisco NX-OS and Cisco IOS Software Differences

In Cisco NX-OS:

  • 528 Port-Channels are supported per chassis in Cisco NX-OS Software release 5.2(1). 256 Port-channels were supported prior to Cisco NX-OS Software release 5.2(1).
  • A Port-Channel interface number can be configured to use numbers 1 - 4096 per VDC. The Cisco IOS Software uses numbers 1-256 per chassis.
  • LaCP and Static Mode Port-Channels are supported (PaGP is not supported in Cisco NX-OS Software).
  • LaCP command-line interface (CLI) configuration and verification commands are not available until you enable the LaCP feature with the feature lacp command.
  • A Port-Channel configured on F series modules supports up to 16 active members. Cisco IOS Software supports 8 active members.
  • The CLI syntax for specifying multiple interfaces is different in Cisco NX-OS Software. The range keyword has been omitted from the syntax (IE: interface ethernet 1/1-2)
  • A Port-Channel can be converted between a layer-2 and layer-3 Port-Channel without removing the member ports.
  • The force keyword can be used when adding an interface to an existing Port-Channel to force the new interface to inherit all of the existing Port-Channel compatibility parameters.
  • Bidirectional Forwarding Detection (BFD) can be configured with supporting protocols (IE: BGP, OSPF, PIM, etc...) over a Port-Channel interface. Cisco IOS Software does not support BFD on Port-Channel interfaces.


Things You Should Know

The following list provides some additional facts about the Cisco NX-OS that should be helpful when designing, configuring, and maintaining a network using Port-Channels.


  • A single Port-Channel cannot connect to two different VDCs in the same chassis.
  • A single Port-Channel cannot connect to an M series and F series module simultaneously.
  • Do not mix dedicated and shared member ports when configuring a port channel using M series modules.
  • You cannot disable LaCP with the no feature lacp command if LaCP is configured for a Port-Channel. LaCP must be disabled on all Port-Channels prior to disabling LaCP globally.
  • The LaCP rate timer can be configured per physical interface using the lacp rate interface command (normal (default) = 30 seconds and fast = 1 second).
  • The lacp min-links interface command can be configured to guarantee bandwidth by preventing a low-bandwidth port-channel from becoming active if the minimum numbers of links are not operational.
  • By default, the load-balancing method for IP traffic is configured for source-dest-ip address and Non-IP traffic is configured for source-dest-mac address.
  • The show port-channel compatibility-parameters command is very useful for verifying interface parameters when configuring Port-Channels.
  • The show port-channel load-balance forwarding-path command can be used to determine the individual link a flow traverses over a specific Port-Channel.
  • The show running-config interface port-channel <#> command can be used to verify the configuration for a specific port-channel interface.


Configuration Comparison

The following sample code shows configuration similarities and differences between the Cisco NX-OS and Cisco IOS Software CLIs. The CLI is very similar between Cisco IOS and Cisco NX-OS. Cisco NX-OS does not use the range keyword when specifying multiple interfaces. Cisco NX-OS also has the ability to force an interface to inherit existing Port-Channel compatibility parameters using the force keyword.

Cisco IOS CLI Cisco NX-OS CLI
Enabling the LaCP Feature
Cisco IOS Software does not have the ability to enable or disable LaCP. feature lacp
Configuring LaCP Active Mode
interface range gigabitethernet 1/1-2

channel-group 1 mode active

interface ethernet 1/1-2

channel-group 1 mode active

Configuring LaCP Passive Mode
interface range gigabitethernet 1/1-2

channel-group 1 mode passive

interface ethernet 1/1-2

channel-group 1 mode passive

Configuring the LaCP Rate Timer (Fast)
interface gigabitethernet 1/1

lacp rate fast

interface ethernet1/1

lacp rate fast

Configuring the LaCP Min/Max Links
interface port-channel 1

port-channel min-links 2

lacp max-bundle 4

interface port-channel 1

lacp min-links 2

lacp max-bundle 4

Configuring Static Mode (no protocol)
interface range gigabitethernet 1/1-2

channel-group 1 mode on

interface ethernet 1/1-2

channel-group 1 mode on

Enabling a Port Channel
interface port-channel 1

no shutdown

interface port-channel 1

no shutdown

Layer-2 Port-Channel Example
interface range gigabitethernet 1/1-2

switchport

channel-group 1 mode active


interface port-channel 1

no shutdown

interface ethernet 1/1-2

switchport

channel-group 1 mode active


interface port-channel 1

no shutdown

Layer-3 Port-Channel Example
interface range gigabitethernet 1/1-2

no switchport

channel-group 1 mode active


interface port-channel 1

ip address 192.168.1.1 255.255.255.0

no shutdown

interface ethernet 1/1-2

no switchport

channel-group 1 mode active


interface port-channel 1

ip address 192.168.1.1/32

no shutdown

Adding an Interface to an Existing Port-Channel
Cisco IOS Software does not have the force option, so all interface parameters have to be compatible prior to adding the interface to an existing Port-Channel.


interface range gigabitethernet 1/3

no switchport

channel-group 1 mode active[

interface ethernet 1/3

channel-group 1 force mode active

Configuring the System Load-Balance Algorithm
port-channel load-balance dst-mac port-channel load-balance ethernet destination-mac
Configuring the Load-Balance Algorithm per Module
port-channel per-module load-balance

port-channel load-balance dst-mac module 1

port-channel load-balance ethernet destination-mac module 1



Verification Command Comparison

The following table lists some useful show commands for verifying and troubleshooting a Port-Channel configuration.


Cisco NX-OS Port-Channels Cisco IOS Software Port-Channels Command Description
show interface show interface Displays statistics all interfaces or a specific interface
show interface port-channel <#> show interface port-channel <#> Displays statistics for a specific port-channel
- - -
show port-channel capacity - Displays port-channel resources (total, used, free)
show port-channel compatibility-parameters - Displays the compatibility-parameters (IE: speed, duplex, etc)
show port-channel database - Displays the aggregation state for one or more port-channels
show port-channel load-balance show etherchannel load-balance Displays the load-balancing algorithm (hash) configured
show port-channel load-balance forwarding-path show etherchannel load-balance hash-result Displays packet forwarding information
show port-channel summary show etherchannel summary Displays a summarized list of all port-channels
show port-channel traffic - Displays the load per link in a port-channel (Based in interface counters)
show port-channel usage - Displays the range of used and unused port-channel numbers
- - -
show lacp counters show lacp counters Displays the LaCP PDU and error counters
show lacp interface - Displays detailed LaCP information per interface
show lacp neighbors show lacp neighbors Displays detailed LaCP information per neighbor
show lacp port-channel show lacp <port-channel-#> Displays the port-channel LaCP configuration
show lacp system-identifier show lacp sys-id Displays the LaCP system ID (Priority / MAC address)

Rating: 4.7/5 (24 votes cast)

Personal tools