Cisco Application Control Engine (ACE) Configuration Examples -- Routing and Bridging Configuration Examples

From DocWiki

Jump to: navigation, search

This article provides examples of routing and bridging configurations. For details about configuring routing and bridging on the ACE, see the Cisco Application Control Engine Module Routing and Bridging Configuration Guide.

To return to the main article, click here.


Contents


Example of a Bridged Configuration

The following example shows a basic bridged mode configuration. In this mode, VLANs 40 and 41 are bridged, so that packets are flooded from one VLAN to the other. The context VC_WEB shares both VLANs in the bridge group. Note that all other configuration examples in this wiki are examples of routed mode.

access-list INBOUND extended permit ip any

probe tcp TCP_PROBE1

rserver host RS_WEB5
  description content server web-five
  ip address 10.15.3.11
  inservice
rserver host RS_WEB6
  description content server web-six
  ip address 10.15.3.12
  inservice
rserver host RS_WEB7
  description content server web-seven
  ip address 10.15.3.13
  inservice
rserver host RS_WEB8
  description content server web-eight
  ip address 10.15.3.14
  inservice

serverfarm SF_WEB2
   probe TCP_PROBE1
  rserver RS_WEB5 80
     inservice
  rserver RS_WEB6 80
     inservice
  rserver RS_WEB7 80
     inservice
  rserver RS_WEB8 80
     inservice

policy-map type loadbalance first-match HTTP_LB
  class-default
     serverfarm SF_WEB2

class-map VS_WEB2
  match virtual-address 10.15.3.100 any

policy-map multi-match HTTP_MULTI_MATCH
  class VS_WEB2
     loadbalance policy HTTP_LB
     loadbalance vip inservice

interface bvi 1
  description Client and server bridge group 1
 ip address 10.15.3.5 255.255.255.0
  no shutdown

interface vlan 40
  description Client_side
  bridge-group 1
  access-group input INBOUND
  service-policy input HTTP_MULTI_MATCH
  no shutdown

interface vlan 41
  description Server-side
  bridge-group 1
  no shutdown

context VC_WEB
  allocate-interface vlan 40
  allocate-interface vlan 41
  member RC_WEB

ip route 0.0.0.0 0.0.0.0 10.15.3.1

Example of a One-Arm Configuration

The following example shows how to configure one-arm mode. In one-arm mode, the clients and the servers are in the same VLAN.


Ace one arm.jpg


access-list INBOUND extended permit ip any any

probe tcp TCP_PROBE2

rserver host RS_WEB9
  description content server web-nine
  ip address 192.168.5.11
  inservice
rserver host RS_WEB10
  description content server web-ten
  ip address 192.168.5.12
  inservice
rserver host RS_WEB11
  description content server web-eleven
  ip address 192.168.5.13
  inservice
rserver host RS_WEB12
  description content server web-twelve
  ip address 192.168.5.14
  inservice

serverfarm SF_WEB3
  probe TCP_PROBE2
  rserver RS_WEB9 80
    inservice
  rserver RS_WEB10 80
    inservice
  rserver RS_WEB11 80
    inservice
  rserver RS_WEB12 80
    inservice

policy-map type loadbalance first-match PM_ONE_ARM_LB
  class class-default
    serverfarm SF_WEB3

class-map VS_WEB3
  match virtual-address 172.16.5.100 any

policy-map multi-match PM_ONE_ARM_MULTI_MATCH
  class VS_WEB3
    loadbalance policy PM_ONE_ARM_LB
    loadbalance vip inservice
    loadbalance vip icmp-reply active
    nat dynamic 5 vlan 100
  
 
interface vlan 100
  description Client_server
  ip address 172.16.5.5 255.255.255.0
  access-group input INBOUND
  service-policy input PM_ONE_ARM_MULTI_MATCH
  nat-pool 5 172.16.5.200 172.16.5.209 netmask 255.255.255.0 pat
  no shutdown

context VC_WEB
  allocate-interface vlan 100
  member RC_WEB

ip route 0.0.0.0 0.0.0.0 172.16.5.1

Rating: 2.4/5 (7 votes cast)

Personal tools