Unified SIP Proxy - Upgrading

From DocWiki

(Difference between revisions)
Jump to: navigation, search
(Cisco Unified SIP Proxy - Upgrading)
 
(15 intermediate revisions not shown)
Line 1: Line 1:
-
[[Category: Unified SIP Proxy]]
+
{{Template:Required Metadata}}
 +
'''Return to the main Cisco Unified SIP Proxy DocWiki page:'''  [[Cisco Unified SIP Proxy]]
-
The latest version of the Unified SIP Proxy is 1.1.4.  To upgrade from previous releases, follow these steps:
 
-
1) Backup your CUSP config!!! This is important, because upgrading the code erases your configuration.  Also, make sure you are in hostname(cusp)# when you copy the config out.  The easiest way to back the config up is the following command:
 
-
hostname(cusp)#copy config active ftp:
 
-
This will allow you to specify the IP address of an FTP server to back your configuration up.  I would also highly recommend you go to the FTP server and verify that your CUSP config did indeed get transfered and that you can view the file without any problems.  You will be restoring from this file shortly.
+
==Upgrading to Cisco Unified SIP Proxy Release 8.5==
-
2) Double check that you have performed step number 1. Can you tell I've been burned here?
+
To upgrade to Cisco Unified SIP Proxy Release 8.5 from an earlier release, follow the instructions in the ''Installation Guide for Cisco Unified SIP Proxy Release 8.5'' at http://www.cisco.com/en/US/docs/voice_ip_comm/cusp/rel8_5/install/cusp_install.html
-
3) There are three files you need to have downloaded from CCO for the upgrade to work.  They are:
 
-
cusp-k9.nme.1.1.4.pkg
 
-
cusp-full-k9-nme.1.1.4.prt1
 
-
cusp-installer-k9.nme.1.1.4.prt1
 
-
These need to be on an FTP server somewhere with an anonymous account (with any password accepted) setup.  You DO NOT have the option to input a username and password when initiating the install on the CUSP CLI.  When you are on the CLI of the NME and you start typing software install, you have a few different options.  One of them is upgrade.  Guess what?  upgrade is not a valid option for upgrading your CUSP software.  The only option that is valid is clean.  The full syntax for the upgrade is software install clean url ftp://10.0.0.1/cusp-k9.nme.1.1.4.pkg.  And yes, referring back to step 1, a clean install ERASES your config.
 
-
4) The NME reboots and begins the initialization wizard.  Your NME config gets saved in flash, so you'll be prompted to restore that.  Once it has reached the hostname> prompt, type cusp to go into cusp EXEC mode, and then type in copy ftp: config active.  Here you'll specify the IP address of the FTP server used in step 1 to back your old configuration up.  You'll also need to know the name of the file as it was saved to the FTP server.  By default it's hostname.cusp.cfg (where hostname is whatever you named your cusp NME).  A reboot will take place once the file is transferred, and this completes the upgrade process.
+
==Upgrading to Cisco Unified SIP Proxy Release 1.1.4==
 +
 
 +
To upgrade to Cisco Unified SIP Proxy Release 1.1.4 from an earlier release, follow these steps:
 +
 
 +
 
 +
#Back up your Cisco Unified SIP Proxy configuration. This is important, because upgrading the code erases your configuration.  Also, make sure you are in hostname(cusp)# when you copy the configuration out.  The easiest way to back up the configuration is to use the following command: "hostname(cusp)#copy config active ftp:"
 +
#:
 +
#:Using this command allows you to specify the IP address of an FTP server to back up your configuration. 
 +
#:
 +
#Go to the FTP server and verify that your Cisco Unified SIP Proxy configuration did indeed get transferred and that you can view the file without any problems.  You will be restoring from this file shortly.
 +
#:
 +
#Download the following files from cisco.com to an FTP server somewhere with an anonymous account (with any password accepted) setup.:
 +
#* cusp-k9.nme.1.1.4.pkg
 +
#* cusp-full-k9-nme.1.1.4.prt1
 +
#* cusp-installer-k9.nme.1.1.4.prt1
 +
#:'''NOTE:''' You DO NOT have the option to input a username and password when initiating the install on the Cisco Unified SIP Proxy CLI. 
 +
#:
 +
#Go to the CLI of the NME.  Start typing "software install" and the system will give you a few different options.  One of them is "upgrade". Unfortunately, "upgrade" is not a valid option for upgrading your Cisco Unified SIP Proxy software.  The only option that is valid is "clean".  The full syntax for the upgrade is "software install clean url ftp://10.0.0.1/cusp-k9.nme.1.1.4.pkg". 
 +
#:
 +
#:'''NOTE:'''  A clean install ERASES your config.  So be sure that you backed up your config before you do this.
 +
#:
 +
#The NME reboots and begins the initialization wizard.  Your NME config gets saved in flash, so you'll be prompted to restore that.  Once it has reached the hostname> prompt, type "cusp" to go into CUSP EXEC mode, and then type in "copy ftp: config active".  Here you'll specify the IP address of the FTP server used in step 1 to back your old configuration up.  You'll also need to know the name of the file as it was saved to the FTP server.  By default it is "<''hostname''>.cusp.cfg" (where <''hostname''> is whatever you named your CUSP NME).  A reboot will take place once the file is transferred, and this completes the upgrade process.
 +
 
 +
 
 +
[[Category: Unified SIP Proxy]]

Latest revision as of 22:28, 16 November 2010

Return to the main Cisco Unified SIP Proxy DocWiki page: Cisco Unified SIP Proxy



Upgrading to Cisco Unified SIP Proxy Release 8.5

To upgrade to Cisco Unified SIP Proxy Release 8.5 from an earlier release, follow the instructions in the Installation Guide for Cisco Unified SIP Proxy Release 8.5 at http://www.cisco.com/en/US/docs/voice_ip_comm/cusp/rel8_5/install/cusp_install.html



Upgrading to Cisco Unified SIP Proxy Release 1.1.4

To upgrade to Cisco Unified SIP Proxy Release 1.1.4 from an earlier release, follow these steps:


  1. Back up your Cisco Unified SIP Proxy configuration. This is important, because upgrading the code erases your configuration. Also, make sure you are in hostname(cusp)# when you copy the configuration out. The easiest way to back up the configuration is to use the following command: "hostname(cusp)#copy config active ftp:"
    Using this command allows you to specify the IP address of an FTP server to back up your configuration.
  2. Go to the FTP server and verify that your Cisco Unified SIP Proxy configuration did indeed get transferred and that you can view the file without any problems. You will be restoring from this file shortly.
  3. Download the following files from cisco.com to an FTP server somewhere with an anonymous account (with any password accepted) setup.:
    • cusp-k9.nme.1.1.4.pkg
    • cusp-full-k9-nme.1.1.4.prt1
    • cusp-installer-k9.nme.1.1.4.prt1
    NOTE: You DO NOT have the option to input a username and password when initiating the install on the Cisco Unified SIP Proxy CLI.
  4. Go to the CLI of the NME. Start typing "software install" and the system will give you a few different options. One of them is "upgrade". Unfortunately, "upgrade" is not a valid option for upgrading your Cisco Unified SIP Proxy software. The only option that is valid is "clean". The full syntax for the upgrade is "software install clean url ftp://10.0.0.1/cusp-k9.nme.1.1.4.pkg".
    NOTE: A clean install ERASES your config. So be sure that you backed up your config before you do this.
  5. The NME reboots and begins the initialization wizard. Your NME config gets saved in flash, so you'll be prompted to restore that. Once it has reached the hostname> prompt, type "cusp" to go into CUSP EXEC mode, and then type in "copy ftp: config active". Here you'll specify the IP address of the FTP server used in step 1 to back your old configuration up. You'll also need to know the name of the file as it was saved to the FTP server. By default it is "<hostname>.cusp.cfg" (where <hostname> is whatever you named your CUSP NME). A reboot will take place once the file is transferred, and this completes the upgrade process.

Rating: 0.0/5 (0 votes cast)

Personal tools