Unified CVP Call Studio: Procedure to enable TLS 1.2 support for Unified CVP Call Studio Web Services

From DocWiki

Revision as of 17:37, 23 September 2017 by Gorourke (Talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Procedure to enable TLS 1.2 support for Unified CVP Call Studio Web Services

Problem Summary In Call Studio Web Service Element, TLS 1.0 is negotiated even if Web Service Server supports TLS1.2.
Error Message None
Possible Cause JRE 7 uses TLS1.0 by default.
Recommended Action

Install patch CVP 10.5 – ES24, CVP 11.0 – ES23, CVP 11.5 – ES7 for Unified CVP Release 10.5, 11.0 and 11.5 respectively.

This patch forces the Java to set the context for TLS 1.2 so all outgoing https requests from CVP will use TLS 1.2.

Release 10.5, 11.0 and 11.5
Associated CDETS # CSCvc39129

Note: You also need to include the following parameter in the VXML Server Tomcat Parameters and restart the server:
-Dhttps.protocols=TLSv1.1,TLSv1.2
Registry Options Location:
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\VXMLServer\Parameters\Java\Options]
--Gorourke 13:37, 23 September 2017 (EDT)

Rating: 1.0/5 (1 vote cast)

Personal tools