Unified CCE Software Compatibility Matrix for 10.0(x)

From DocWiki

(Difference between revisions)
Jump to: navigation, search
m (1 revision)
(VDI & Cisco VXI Support)
Line 853: Line 853:
| valign="top" | Cisco Finesse<br>  
| valign="top" | Cisco Finesse<br>  
| valign="top" | 10.0(1)<br>  
| valign="top" | 10.0(1)<br>  
-
| valign="top" | Citrix XenDesktop 4.x, 5.0, 5.5, 6.0, 6.5, 7.0<br>  
+
| valign="top" | Citrix XenDesktop 4.x, 5.0, 5.5, 6.0, 6.5, 7.0, 7.1<br>  
| valign="top" | Windows 7 (32 bit, 64 bit, and WOW64)  
| valign="top" | Windows 7 (32 bit, 64 bit, and WOW64)  
Windows XP<br>  
Windows XP<br>  

Revision as of 01:48, 7 March 2014


Go to: Guidelines to Edit the Compatibility Matrix for Unified CCE

Go to: Compatibility Matrix for Unified CCE

Go to: Category:Unified Contact Center Enterprise


Introduction

This compatibility matrix specifies all supported configurations and versions for Cisco Unified Contact Center Enterprise 10.0(1). The information in this compatibility matrix supersedes compatibility information in any other Cisco Unified Contact Center Enterprise documentation. If a configuration or version is not stated, that configuration or version is not supported.




Contents

Unified CCE 10.0(1) Product Sets 

Unified CM4 IVR (IP-IVR
and CVP)

PG/CAD/CTI OS
Server1,2


CTI OS
Desktop1


Unified
Intelligence
Center
Unified
EIM/WIM

Siebel CRM

 RSM

 

Unified CCMP

MediaSense SocialMiner Finesse
10.0(1)

IP-IVR
10.0(1)

9.0(1)

CVP
10.0(1)
9.0(1)

PG
10.0(1)

CAD
10.0(1)

CTI OS Server
10.0(1) 

10.0(1)

9.0(x)

8.5(x)

10.0(1)

9.1(x)

9.0(x)


EIM WIM 9.0(2)



CRM for Siebel
8.0(x)
8.1(x)

10.0(1)

9.0(1)
9.1(1)
8.5(2)


10.0(1)

10.0(1)

10.0(1)

10.0(1)


9.1(1)
9.1(2)

IP-IVR
9.0(x)
8.5(x)

CVP
10.0(1)
9.0(1)

PG
10.0(1)

CAD
10.0(1)

CTI OS Server
10.0(1)

10.0(1)

9.0(x)

8.5(x)

10.0(1)

9.1(x)

9.0(x)


EIM WIM 9.0(1)

EIM 4.3(2)

EIM WIM 4.4(1)

CRM for Siebel
8.0(x)
8.1(x)

10.0(1)

9.1(1)
9.0(1)
8.5(2)

10.0(1)

9.0(1)

N/A

10.0(1)

9.0(1)

IP-IVR
9.0(x)
8.5(x)

CVP
10.0(1)
9.0(1)

PG
10.0(1)

CAD
10.0(1)

CTI OS Server
10.0(1)

10.0(1)

9.0(x)

8.5(x)

10.0(1)

9.1(x)

9.0(x)


EIM WIM 9.0(1)

EIM 4.3(2)

EIM WIM 4.4(1)

CRM for Siebel
8.0(x)
8.1(x)

10.0(1)

9.1(1)
9.0(1)
8.5(2)

10.0(1)

9.0(1)

N/A

10.0(1)

8.6(x)

IP-IVR
9.0(x)
8.5(x)

CVP
10.0(1)
9.0(1)

PG
10.0(1)

CAD
10.0(1)

CTI OS Server
10.0(1)

10.0(1)

9.0(x)

8.5(x)

10.0(1)

9.1(x)

9.0(x)


EIM WIM 9.0(1)

EIM
4.3(2)

EIM WIM
4.4(1)

CRM for Siebel
8.0(x)
8.1(x)

10.0(1)
9.1(1)
9.0(1)
8.5(2)
10.0(1) 9.0(1) N/A 10.0(1)

1The PG, CTI Server, and CTI OS server versions must all be at the same version. Additionally, the PG, CTI Server, CTI OS Server, and CTI OS desktop versions cannot be higher than the Central Controller version.
2The CAD client and servers must all be at the same version. CAD clients and CAD server versions must be at the same major and minor release as the PG, CTI Server, and CTI OS Server and the CAD clients and CAD servers versions cannot be at a higher maintenance release than the PG, CTIS Server, and CTI OS Server versions.

Additional Unified CCE 10.0(1) Notes

  • Outbound Option SIP Dialer:
    Supports 28xx, 3845, AS5350xm, and AS5400xm gateways with a PVDM2 DSP card
    Supports ISR G2 gateways (29xx and 39xx) with PVDM3 DSP card
    When needed for design, requires Cisco Unified SIP Proxy Version 8.5(1) or later
    Supports IOS Release 15.2(3)T, and 15.2(4)M1, 15.2(4)M2, 15.1(4)M5. CUBE is allowed between the Gateways and rest of UCCE/ICM solution only when implementing MediaSense. Please reference the MediaSense SRND for full implementation details.
    Cisco Finesse feature information, including that of Outbound Option support, can be found in the Cisco Finesse, Cisco Agent Desktop, and Cisco CTI OS Feature Comparison Guide http://www.cisco.com/en/US/partner/prod/collateral/voicesw/custcosw/ps5693/ps11324/product_bulletin_c25-695211.html.
  • Unified Communications Manager 10.0(x) is supported with a Unified CCE 10.0(x) Peripheral Gateway (PG) only. Unified CCE 10.0(x) Central Controller supports PGs running at the following versions for backward compatibility during upgrade: 9.0(x) and 8.5(x). For UCM compatibility for these PGs, see the UCM Compatibility Guide.
  • The following general limitations pertain to Unified CCE deployments that use the System Peripheral Gateways(PG):E-Mail Manager Option, Web Collaboration Option (both end-of-life products), as well as E-Mail Interaction Manager and Web Interaction Manager (Unified EIM/WIM) are not supported with deployments that use the System PG. For Unified EIM/WIM documentation, see:Cisco Unified E-Mail Interaction Manager and Cisco Unified Web Interaction Manager.


IP Phone Support

The Contact Center Enterprise Design Guide includes additional details, caveats, and feature details associated with each of these specific phone devices.


Endpoint Family Specific Device Notes
Jabber for Windows Release 9.2 of Jabber for Windows is supported with Cisco Finesse 9.1. No support for CTI-OS or CAD at this time. Support includes voice media termination but Video is not supported.
CTS-500 Telepresence CTS-500 TP is supported as a Video Remote Expert (VRE) kiosk only.
Tandberg EX EX60, EX90 are supported in Video Remote Expert (VRE) solutions only.
The EX family is not supported with Unified CM based Silent Monitor, RSM, Agent Greeting, or Whisper Announcement.
DX650 DX650 versions of Cisco IP Phones are supported.
99xx family 9951 and 9971 are supported.
89xx family 8941, 8945, 8961 are supported.
797x 7970 is not supported with Unified CM based Silent Monitor or RSM.
7975 only is supported with Agent Greeting or Whisper Announcement.
796x 7961, 7962, and 7965 are supported.
The 7960 model is not supported with Unified CM based Silent Monitor, RSM, or Agent Greeting and Whisper Announcement.
794x 7941, 7942, and 7945 are supported.
The 7940 model is not supported with Unified CM based Silent Monitor, RSM, Agent Greeting, or Whisper Announcement.
793x Family not supported
792x 7921 and 7925 are supported.
The 792x family is not supported with Agent Greeting or Whisper Announcement.
791x 7911 is supported.
The 791x family is not supported with Unified CCE based Silent Monitor, RSM, Agent Greeting, or Whisper Announcement.
78xx family 7821, 7841, and 7861 are supported.
69xx family 6921, 6941, 6961, and 6945 are supported.
Cisco IP Communicator Versions 7.0(x) and 8.6(x) are supported.
Version 7.0(x) is not supported with Agent Greeting and Whisper Announcement.
CIPC does not support Mobile Agents.
78xx family 7821, 7841, and 7861 are supported.


The following general limitations pertain to IP phones used with Unified CCE Enterprise deployments:

  • Third-party SIP phones are not supported as contact center agent phones. The SIP standard does not include the necessary messaging for third-party Call Control (3PCC). Unified CCE relies on CTI capabilities on the SIP phones that third-party phones do not have. As an alternative, you may choose to deploy the Mobile Agent solution to enable Cisco Unified CCE and Contact Center Hosted (CCH) to use any phone as an agent phone. Please consult with your Cisco Sales Engineer for additional detail on this configuration.
  • IP Communicator is not supported with Cisco Agent Desktop (CAD) IP Phone Agent.
  • See the Cisco Unified Communications Manager Compatibility Guide for SIP and other phone protocol support.


Microsoft System Software Requirements


Microsoft Windows Server 2008 R2

Microsoft Windows Server 2008 R2 is supported. Be aware of the following distinction between the editions.

IMPORTANT: Currently only SP1 for Microsoft Windows Server 2008 R2 is supported.

Microsoft Windows Server 2008 Standard Edition

  • Supports up to four processors on one 64-bit server
  • Maximum 32 GB of RAM

Microsoft Windows Server 2008 Enterprise Edition

  • Supports up to eight processors on one 64-bit server
  • Maximum two Terabytes (TB) of RAM

IMPORTANT: Unified ICM/CCE is qualified to work only on a standard packaged installation of Microsoft Windows Server 2008 R2 (Standard or Enterprise). Cisco does not support Unified ICM/CCE on a customized Windows image (for example, a corporate image). Using a customized image of the Windows operating system can cause the Unified ICM/CCE application to fail.

Microsoft SQL Server 2008 R2

Microsoft SQL Server 2008 R2 Standard Edition

  • CPU: Supports up to four processors on one server
  • RAM: No operating system maximum
  • SP2

Microsoft SQL Server 2008 R2 Enterprise Edition

  • CPU: No operating system maximum
  • RAM: No operating system maximum
  • SP2


Microsoft Windows and Microsoft SQL Server Localization Support

The following table lists supported localized versions of Microsoft Windows Server and SQL Server that can be used with Cisco Unified ICM/Unified Contact Center Enterprise and Hosted system components.

Supported Microsoft Software Localizations
Microsoft Windows Server 2008 R2 Microsoft SQL Server 2008 R2 SQL Collation Setting
Danish
Latin1_General
Dutch
Finnish
French French
German German
Italian Italian
Norwegian
Portuguese (Brazil) Portuguese (Brazil)
Spanish Spanish
Swedish
Chinese (simplified) Chinese (simplified) Chinese_PRC
Chinese (traditional) Chinese (traditional) Chinese_Taiwan_Stroke
Japanese Japanese Japanese
Korean Korean Korean_Wansung
Polish
Polish
Russian
Cyrillic_General
Turkish
Turkish

If there is not a corresponding localized SQL Server 2008 (listed in the Microsoft SQL Server 2008 R2 column) for a particular language listed in the Microsoft Windows Server 2008 R2 column, use the English SQL Server 2008 with the applicable setting listed in the SQL Collation Setting column.

Cisco Unified Contact Center Enterprise and Cisco Packaged Content Center Enterprise both support multilingual versions of Microsoft Windows Server 2008 R2 (English Windows Server 2008 with language packs installed). For details about how to set up multilingual versions of Microsoft Windows Server 2008 R2, see the Cisco Unified Contact Center Enterprise Installation and Upgrade Guide.

English SQL Server 2008 must be used on multilingual versions of the Microsoft Windows Server 2008 R2 environment. Following are two valid examples of supported multilingual environments:

  • English Windows Server 2008 with Japanese Windows language pack installed, and English SQL Server 2008 with Japanese SQL Collation Setting.
  • English Windows Server 2008 with Russian Windows language pack installed, and English SQL Server 2008 with Cyrillic_General SQL Collation Setting.


Java Requirements

Unified CCE Release 10 installs with Java 6 Update 30 and can be upgraded to the latest Java 6 Update. Java 7 is not supported.


Operating System and Database Requirements

The following table presents operating system requirements that are specific to the Unified ICM/CCE server type. The next table covers Unified ICM/CCE servers and client desktop deployments that require special consideration.

Operating System and Database Requirements, Unified ICME/ICMH/CCE/CCH
Unified ICM/CCE Server Microsoft Windows Server 2008 R2 MS SQL Server 2008 R2
ICM Router
NAM Router
CICM Router
Progger (Unified CCE)
Rogger (Unified CCE)
NAM Rogger (Unified CCH)
Administration & Data Server
All PGs; includes:
  • CCE Agent PG
  • TDM ACD PG
  • VRU PG
  • MR PG
  • Outbound Option Dialer
1
Unified CC Enterprise Gateway PG
SS7 or Sigtran Gateway
ICM Logger
NAM Logger
CICM Logger
HDS & DDS

1SQL Server is not required unless CAD is installed.



Special Considerations (OS and DB Requirements), Unified ICME/ICMH/CCE/CCH
Unified ICM/CCE Server Operating System Requirements
Administration Client Requires Windows 7 or Windows XP SP3.
CUIC Client See the CUIC BOM specification documentation.
CTI OS Desktops See CTI Supported Platforms.
CTI OS See CTI Supported Platforms.


CTI Supported Platforms

CTI Supported Platforms
CTI Option Operating System
Server Platform Client Platforms
Microsoft Windows Server 2008 R2 (SP1) Windows XP Professional; SP2 Windows XP Professional; SP3 Windows 7 (Pro, Enterprise, and Ultimate)1 Mac OS X
CTI OS Server
Cisco Data Store
Silent Monitor Server (standalone)
Silent Monitor Service for Unified CC Toolkit
CTI Driver for Siebel
CTI OS - CTI toolkit Supervisor Desktop
CTI OS - CTI toolkit Agent Desktop
CTI OS - CTI toolkit Combo Desktop .NET
CTI OS - Custom Apps using C++ or COM CIL
CTI OS - Custom Apps using Java CIL
√ (V5.0)
CTI OS - Custom Apps using .NET CIL
CTI OS - Monitor Mode Apps using C++, COM, or .NET CIL
CTI OS - Monitor Mode Apps using Java CIL
√ (V5.0)
CAD
√ (v4.0 or 5.0)
Cisco Finesse

1Any customizations to the CTI OS toolkit must be compiled under the development environment supported in Release 10.0(1)and then deployed on Windows 7. For further information, refer to the CTI OS Developer Guide. Existing customized CTI OS desktops can be moved to Windows 7 without the need for recompilation. Visual Studio 2008 is not supported.

Supported Third-Party Software

Supported Third-Party Software
Function Software
Remote Administration For Remote Desktop usage information, see the "Remote Administration” section in Security Best Practices Guide for Cisco Unified ICM/Contact Center Enterprise & Hosted.
Antivirus Software
  • McAfee Virus Scan Enterprise 8.8i
  • Symantec Endpoint Protection 11.0/12.1
  • Trend MicroServerProtect Version 5.7/5.8



UCCE Release 10.0.(1) Supported Browsers

Release 10.0(1) components support:

  • Internet Explore 9.0
  • Firefox24 and higher (we make every effort to test and support the most recent versions of Firefox)

Exceptions to the browser compatibility are:

  • Reskilling Tool (does not support Firefox)
  • Web Setup (does not support Firefox)
  • Admin Client Setup Tool (does not support Firefox)
  • EIM/WIM 9.0(2) Agent Desktop and higher (does not support Firefox)



Unified CCE Parent / Child Compatibility

Release
Parent 8.5(x) Parent 9.0(x) Parent 10.0(x)
Child 8.5(x) Yes
Yes
Yes
Child 9.0(x) Yes
Yes
Yes
Child 10.0(x) Yes
Yes
Yes


Central Controller Backward Compatibility

CentralController PG PG + CAD
10.0 9.0 9.0
10.0 8.5 8.5


Note: Backward compatible PGs are intended to be supported during the transition when you upgrade the Central Controller and PGs to the same version.

Note: MR PG and Dialer must be at the same version.

Note: For Outbound deployments, ES18 must be installed with UCCE 8.5(4) to work with Central Controller 9.x and 10.x.


NAM/CICM Compatibility

NAM Version CICM Version
10.0
9.0
10.0 8.5


Note: The columns can be switched for forward compatibilty. For example, CICM at 10.0 and NAM at 9.0 is a supported configuration.

VDI & Cisco VXI Support

Cisco Client Type Version Virtual Desktop Infrastructure OS Compatibility Cisco VXI Clients
CTI-OS Clients (All CILs) 8.5(x), 9.0, 10.0(1) VMWare View 4.6, 5.0 Windows 7 32 bit - Supported
Windows 7 WoW64 - Supported
Windows XP 32 bit - Supported

VXC 2100 - N/A
VXC 2200 - N/A
VXC 2111 - Supported with Cisco Unified IP Phone 8961, 9951, and 9971
VXC 2211 - Supported

VXC6215 - Supported with deskphone only

CTI-OS Clients (All CILs) 8.5(x), 9.0, 10.0(1) Citrix XenDesktop 5.0, 5.5 or 6.0 Windows 7 32 bit - Supported
Windows 7 WoW64 - Supported
Windows XP 32 bit - Supported

VXC 2100 - Supported with Cisco Unified IP Phone 8961, 9951, and 9971
VXC 2200 - Supported
VXC 2111 - N/A
VXC 2211 - N/A

VXC6215 - Supported with deskphone only

CTI-OS Clients (All CILs) 8.5(4), 9.0(2), 10.0(1) Citrix XenDesktop 5.0, 5.5, 6.0, 6.5 Windows 7 32 bit - Supported
Windows 7 WoW64 - Supported
Windows XP 32 bit - Supported

VXC 2100 - Supported with Cisco Unified IP Phone 8961, 9951, and 9971
VXC 2200 - Supported
VXC 2111 - N/A
VXC 2211 - N/A

VXC6215 - Supported with deskphone only

Cisco Finesse
10.0(1)
VMware View 4.6, 5.x

Windows 7 (32 bit, 64 bit, and WOW64)

Windows XP

VXC 2100 - N/A
VXC 2200 - N/A
VXC 2111 - Not Supported
VXC 2211 - Supported

VXC6215 - Supported with deskphone only

Cisco Finesse
10.0(1)
Citrix XenDesktop 4.x, 5.0, 5.5, 6.0, 6.5, 7.0, 7.1
Windows 7 (32 bit, 64 bit, and WOW64)

Windows XP

VXC 2100 - Not Supported
VXC 2200 - Supported
VXC 2111 - N/A
VXC 2211 - N/A

VXC6215 - Supported with deskphone only

Cisco Agent Desktop (CAD) All Not Supported Not Supported Not Supported

Note:

  • UCM Silent Monitoring is the only type of Silent Monitoring that is supported with VXI/VDI.
  • Desktop solutions are supported on PC-like devices only that utilize a keyboard and mouse (no tablets or mobile devices supported at this time).
  • The customer is not required to use Cisco VXI endpoints in a VDI solution. The customer can use any VDI endpoint that supports the specific Citrix or VMWare VDI solution versions supported by Cisco. The customer is responsible for ensuring that bandwidth and any other deployment considerations ensure that the solution can meet the performance and timing requirements of CTI-OS.
  • For information about CAD wih thin client and virtual desktop environments, see the Integrating CAD with Thin Client and Virtual Desktop Environments document.

Application Virtualization

Windows Server 2008 R2 (SP1)

Cisco Client Version CCE Version Citrix/XenApp Remote Desktop Services platform
CTI-OS Clients (All CILs)
10.0(x)
XenApp 6.0
Windows Server 2008 R2 (SP1)



Siebel Compatibility


Cisco Siebel Driver
Siebel Release
10.0(1) 8.1(x)


ICM-to-ICM Gateway Requirements


The following are system requirements for ICM-to-ICM Gateway.

  • Both the Client ICM and Server ICM must be supported releases of Unified ICM, and they must be within one major version of each other. If two connected ICMs are running with different releases of Unified ICM software, only the ICM-to-ICM Gateway features supported by the lowest numbered release are available.


ICM-to-ICM Gateway Client and Server Release Requirements

Client/Server 1 Client/Server 2 Comments
9.0, 10.0 10.0, 9.0 UCCE 10.0(1) is a major release




Back to: Category:Unified Contact Center Enterprise



Rating: 0.0/5 (0 votes cast)

Personal tools