Troubleshooting Cisco Configuration Engine Installation

From DocWiki

Revision as of 10:47, 19 May 2011 by Hsivakum (Talk | contribs)
Jump to: navigation, search

Contents

'gethostbyaddr()' error

Symptom:

Installation aborted with error message “Hostname value retrieval by system calls 'gethostbyaddr()' and command 'hostname' have different values returned. Please correct it also make sure 'ifconfig' is set in your PATH before installing Config Engine 3.5”

Solution: 

To resolve this problem, follow these steps:

Step 1 Make sure the hostnames configured in /etc/hosts, /etc/sysconfig/network and/or DNS server are consistent with what’s returned by “hostname –s” command.

Step 2 Make sure the ifconfig command is in the $PATH environment variable


Can’t reinstall CE

Symptom:

If a install shell is accidentally closed, reinstall is not allowed.

Solution: 

To resolve this problem, follow these steps:

Step 1 use ce_uninstall –force to uninstall any partially installed packages and rerun ce_install.sh again.

Note: If the user typed ^Z to suspend the install process in the background, they need to either resume the install process or kill the install process.

Setup fails in start of httpd

Symptom:

While setting up of Cisco Configuration Engine version 3.5.2 or lower on Red Hat Enterprise Linux Version 5,the setup fails with appliance-setup.log showing httpd start error as mentioned below.

  Starting httpd: /usr/sbin/httpd: error while loading shared libraries: libpq.so.4: cannot open shared object file: No such file or directory

Solution:

The problem is due to missing Red Hat packages on the Red Hat Enterprise Linux. To resolve this problem, follow these steps:

Step 1 Use ce_uninstall to uninstall all installed packages.

Step 2 Install the "postgresql-libs" and "mailcap" rpm for the Red Hat Enterprise Linux Distribution.

Step 3 Rerun the ce_install.sh again to install Cisco Configuration Engine.

Step 4 Launch a new root user Session and enter into a new bash shell.

Step 5 Execute the setup.sh command on the bash shell.

Setup or Resetup of Cisco Configuration Engine fails

Symptom:

The setup/resetup fails with appliance-setup.log showing httpd failure and java not found errors as mentioned below.

 /etc/rc.d/init.d/httpd start 
 Checking if the following ports have been cleared:8009 8005 Starting tomcat...Waiting for tomcat to initialize...
 Starting httpd: FAILED
 system failed: 256 exit_value  = 1 signal_num  = 0 dumped_core = 0
 Deploying config web services ...
 /opt/ConfigEngine/CSCOcnsie/bin/deploy.config.websvc [-wsdl] 
 ./adminclient.sh: line 18: java: command not found


Solution:

The problem is due to non execution of a new bash shell to source the environment variables added by Cisco Configuration Engine. To resolve this problem, follow these steps:

Step 1 Launch a new root user Session and enter into a new bash shell.

Step 2 Execute the setup.sh command on the new bash shell created.

Rating: 0.0/5 (0 votes cast)

Personal tools