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Real-Time Monitoring Tool (RTMT)
The Cisco Unified Presence Real-Time Monitoring Tool (RTMT), which runs as a client-side application,
monitors real-time behavior of Cisco Unified Presence components. The Real-Time Monitoring Tool uses
HTTPS and TCP to monitor system performance, device status, device discovery, and CTI applications for
Cisco Unified Presence. The Real-Time Monitoring Tool can connect directly to devices via HTTPS to
troubleshoot system problems.

Note: Even when RTMT is not running as an application on your desktop, tasks such as alarm and
performance monitoring updates continue to take place on the server in the background.

The Real-Time Monitoring Tool allows you to perform the following tasks:
• Monitor a set of predefined management objects that monitor the health of the system.
• Generate various alerts, in the form of emails, for objects when values go over/below
user-configured thresholds
• Collect and view traces in various default viewers that exist in RTMT
• View syslog messages in SysLog Viewer
Previous Topic
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• Work with performance-monitoring counters

Installing RTMT
You can install RTMT, which works for resolutions 800*600 and above, on a Windows 98, Windows XP,
Windows 2000, or Red Hat Linux with KDE and/or Gnome client.

Before You Begin

• Ensure that the RTMT version that you install is compatible with the Cisco Unified Presence version
that runs in your cluster; for example, the RTMT version that supports Cisco Unified Presence 6.X
does not support Cisco Unified Presence 7.X.
• If you have previously installed RTMT for use with a Cisco Unified Presence server that is running
Microsoft Windows, you must install RTMT for Cisco Unified Presence in a different folder on your
local computer.

Procedure

1. Select Application > Plugins in Cisco Unified Presence Administration.
2. Click Find.
3. Perform one of the following actions:
1. If you are planning to install the RTMT tool on a computer that is running the Microsoft
Windows operating system, click Download for the Cisco Unified Presence Real-Time
Monitoring Tool-Windows.
2. If you are planning to install the RTMT tool on a computer that is running the Linux
operating system, click Download for the Cisco Unified Presence Real-Time Monitoring
Tool-Linux.
4. Download the executable file to your preferred location.
5. Perform one of the following actions:
1. To install the Windows version, double-click the RTMT icon that displays on the desktop or
locate the directory where you downloaded the file and run the RTMT installation file. The
extraction process begins.
2. To install the Linux version, ensure that the file has execute privileges; for example, enter
the following command, which is case sensitive: chmod +x CcmServRtmtPlugin.bin.
6. Click Next.
7. Click Yes to accept the license agreement.
8. Perform one of the following actions:
1. Select the location where you want to install RTMT.
2. If you do not want to use the default location, click Browse and navigate to a different
location. Click Next.
9. Click Next.
10. Click Finish to complete the installation.

Real-Time Monitoring Tool (RTMT)
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Troubleshooting Tips

• Do not click Cancel when the Setup Status window displays.
• While installing RTMT on a Windows Vista computer, you will see a User Account Control pop-up
message that says, "An unidentified program wants to access your computer." Click Allow to
continue working with RTMT.

Related Topics

• Upgrading RTMT
• Uninstalling RTMT
• Getting More Information

What To Do Next

• How to Navigate RTMT

Upgrading RTMT
When you use the RTMT, it saves user preferences and downloaded module jar files locally on the client
computer. The system saves user-created profiles in the Cisco Unified Presence database, so you can access
these items in RTMT after you upgrade the tool.

Before You Begin

To ensure compatibility, Cisco recommends that you upgrade RTMT after you complete the Cisco Unified
Presence upgrade on all servers in the cluster.

Procedure

1. Select Application > Plugins in Cisco Unified Presence Administration.
2. Click Find.
3. Perform one of the following actions:
1. If you are planning to install the RTMT tool on a computer that is running the Microsoft
Windows operating system, click Download for the Cisco Unified Presence Real-Time
Monitoring Tool-Windows.
2. If you are planning to install the RTMT tool on a computer that is running the Linux
operating system, click Download for the Cisco Unified Presence Real-Time Monitoring
Tool-Linux.
4. Download the executable to your preferred location.
5. Perform one of the following actions:
1. To install the Windows version, double-click the RTMT icon that displays on the desktop or
locate the directory where you downloaded the file and run the RTMT installation file. The
extraction process begins.
Troubleshooting Tips
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2. To install the Linux version, ensure that the file has execute privileges; for example, enter
the following command, which is case sensitive: chmod +x CcmServRtmtPlugin.bin.
6. Click Next.
7. Because you cannot change the installation location for upgrades, click Next.
8. Click Finish.

Troubleshooting Tips

Do not click Cancel when the Setup Status window displays.

Related Topics

• Installing RTMT
• Uninstalling RTMT
• Getting More Information

What To Do Next

• How to Navigate RTMT

Installing Multiple Copies of RTMT
A single copy of RTMT that is installed on your computer lets you monitor only one server or one cluster at
a time. For example, you can monitor either of the following entities:
• A Cisco Unified Presence product on one server.
• A node on a cluster to monitor the health of the cluster.
To monitor a product on a different server or node, you must first log off the server or node before you can
log on to the other server.
Multiple copies of RTMT that are installed on your computer let you simultaneously monitor multiple Cisco
Unified Presence products that are installed on different servers.
Note: Beware of the following limitations:
To monitor clusters that are running different versions of Cisco Unified Presence simultaneously, you must
install multiple versions of RTMT (one version per Cisco Unified Presence release). If you install multiple
versions of the plug-in, you can install the versions on the same client as long as the versions exist in
different folders. If the installation detects another version in the folder, a message displays. To continue the
installation, install the version in a different folder.
When you install multiple copies of RTMT on a single computer, you must install RTMT in different folders.
Cisco recommends installing no more than four copies of RTMT on a computer.

Procedure
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Because installing another copy of RTMT overwrites the shortcut icon, you should complete the following
tasks:
1. Create another icon by creating a shortcut to jrtmt.exe in the folder with the previous installation.
2. Rename the icon accordingly.
If the installation detects another version in the selected folder, a message displays. To continue the
installation, install the version in a different folder.
Note: Your computer stores the user preferences, such as the IP address and RTMT frame size, from the
RTMT client that last exits.

Related Topics

• Uninstalling RTMT
• Getting More Information

Uninstalling RTMT
When you use RTMT, it saves user preferences and the module jar files (the cache) locally on the client
computer. The system also saves the cache in the server database. When you uninstall RTMT, you select
whether to delete or save the cache.
Procedure

1. Perform one of the following actions to uninstall RTMT:
1. Click Start > Settings > Control Panel >Add/Remove Programs on a Windows client.
2. Click Start > Accessories > Uninstall Real-time Monitoring tool on a Red Hat Linux with
KDE and/or Gnome client.
2. Finish uninstalling the plug-in.

Troubleshooting Tips

• While uninstalling RTMT on a Windows Vista computer, you will a see a User Account Control
pop-up message that says, "An unidentified program wants to access your computer." Click Allow to
continue working with RTMT.

Related Topics

• How to Install and Upgrade the Real-Time Monitoring Tool (RTMT)
• Getting More Information

Installing Multiple Copies of RTMT
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Services, Servlets, and Service Parameters on the Server
To support the RTMT client, there are a number of services that needs to be active and running on the server.
RTMT uses the following services/servlets:
• Cisco AMC service-This service starts up automatically after the installation and allows RTMT to
retrieve real-time information that exists on nodes in the cluster. Cisco Unified Presence
automatically assigns the first node as the Primary Collector. For RTMT to continue to retrieve
information when the primary collector fails, you must configure a subsequent node as the Failover
Collector in Service Parameters in Cisco Unified Presence Administration.

The following list comprises some Cisco AMC service parameters that are associated with RTMT. For the
latest list of parameters, select System > Service Parameters in Cisco Unified Presence
Administration.Then, select the server and the Cisco AMC service.
• Primary Collector
• Failover Collector
• Data Collection Enabled
• Data Collection Polling Rate
• Server Synchronization Period
• RMI Registry Port Number
• RMI Object Port Number
• Alert Manager Enabled
• Logger Enabled
• Alarm Enabled
For information about these service parameters, click the ? button that displays in the Service
Parameter window of Cisco Unified Presence Administration
• Cisco Communications Manager servlet (in the Control Center-Network Services window in Cisco
Unified Serviceability)-Supports the Cisco Unified Presence Real-Time Monitoring Tool (RTMT),
this service starts up automatically after the installation.
• Cisco RIS Data Collector (in the Control Center-Network Services window in Cisco Unified
Serviceability)-The Real-time Information Server (RIS) maintains real-time information such as
performance counter statistics, critical alarms generated, and so on. The Cisco RIS Data Collector
service provides an interface for applications, such as Real-Time Monitoring Tool (RTMT), SOAP
applications, and AlertMgrCollector (AMC) to retrieve the information that is stored on the server.
• Cisco Tomcat Stats Servlet (in the Control Center-Network Services window in Cisco Unified
Serviceability)-The Cisco Tomcat Stats Servlet allows you to monitor the Tomcat perfmon counters
by using RTMT or the Command Line Interface. Do not stop this service unless you suspect that this
service is using too many resources, such as CPU time.
Services, Servlets, and Service Parameters on the Server
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• Cisco Trace Collection Servlet (in the Control Center-Network Services window in Cisco Unified
Serviceability)-The Cisco Trace Collection Servlet, along with the Cisco Trace Collection Service,
supports trace collection and allows users to view traces by using the RTMT client. If you stop this
service on a server, you cannot collect or view traces on that server.
• Cisco Trace Collection Service (in the Control Center-Network Services window in Cisco Unified
Serviceability)-The Cisco Trace Collection Service, along with the Cisco Trace Collection Servlet,
supports trace collection and allows users to view traces by using the RTMT client. If you stop this
service on a server, you cannot collect or view traces on that server.
• Cisco Log Partition Monitoring Tool (in the Control Center-Network Services window in Cisco
Unified Serviceability)-This service which starts up automatically after the installation, monitors the
disk usage of the log partition on a server.
• Cisco SOAP-Real-Time Service APIs (in the Control Center-Network Services window in Cisco
Unified Serviceability)-The Cisco SOAP-Real-Time Service APIs, which start up automatically after
the installation, allow you to collect real-time information for devices and CTI applications.
• Cisco SOAP-Performance Monitoring APIs (in the Control Center-Network Services window in
Cisco Unified Serviceability)-This service, which starts up automatically after the installation, allows
you to use performance monitoring counters for various applications through SOAP APIs.
• Cisco RTMT Reporter servlet (in the Control Center-Network Services window in Cisco Unified
Serviceability)-This service, which starts up automatically after the installation, allows you to
publish reports for RTMT.

Related Topics

• Getting More Information

How to Navigate RTMT
The RTMT Collector component is automatically installed with the application. It logs preconfigured
monitoring objects information while Alert Manager, also automatically installed, logs alert histories into log
files.
The system also records important perfmon object values in performance log files.
Tip: Although they require no configuration tasks to run, RTMT Collector and Alert Manager support
redundancy.
If the primary collector or manager fails for any reason, the secondary collector and manager perform the
tasks until primary support becomes available. RTMT Collector and Alert Manager run on the first node to
minimize performance impact.
• Launching RTMT
• RTMT Interface

Related Topics
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Launching RTMT
Before You Begin

Cisco AMC Service automatically starts up after installation. Cisco Unified Presence automatically assigns
the first node as the Primary Collector. For RTMT to continue to retrieve information when the primary
collector fails, you must configure a subsequent node as the failover collector in Cisco Unified Presence
Administration.

Procedure

1. After you install the plug-in, select Start > Programs > CallManager > Real-Time Monitoring
Tool.
2. Enter either the IP address or host name of the publisher node in the Host IP Address field.
3. Enter the CCMAdministrator application user username in the User Name field, for example, the
default username for this user is CCMAdministrator.
4. Enter the CCMAdministrator application user password that you established for the username in the
Password field.
5. Enter the port that the application will use to listen to the server. The default setting equals 8443.
6. Check Secure Connection.
7. Click OK.
8. Click Yes to add the certificate store.
Troubleshooting Tips

• While using RTMT on a Windows Vista computer, you will a see a User Account Control pop-up
message that says, "An unidentified program wants to access your computer." Click Allow to
continue working with RTMT.
• If the username and password authentication fails, or if the server is unreachable, the tool prompts
you to reenter the server and authentication details, or you can click Cancel to exit the application.
• After the authentication succeeds, RTMT launches the monitoring module from local cache or from a
remote node, when the local cache does not contain a monitoring module that matches the backend
Cisco Unified Presence version.
Related Topics

• How to Install and Upgrade the Real-Time Monitoring Tool (RTMT)
• Getting More Information

RTMT Interface
The RTMT window comprises the following main components:
• Menu Bar, which includes the following menu options:

Launching RTMT

9

Cisco_Unified_Presence,_Release_7.x_--_How_To_Install_and_Configure_the_Real-Time_Monitoring_Tool_(RTMT)
♦ File-Allows you to save, restore, and delete existing RTMT profiles, monitor Java Heap
Memory Usage, go to the Serviceability Report Archive window in Cisco Unified
Serviceability, log off or exit RTMT.
♦ System-Allows you to monitor system summary, monitor server resources, work with
performance counters, and work with alerts, collect traces, and view syslog messages.
♦ CUP-Allows you to view Cisco Unified Presence summary information on the server.
♦ Edit-Allows you to configure categories (for table format view), set the polling rate for
devices and performance monitoring counters, hide the quick launch channel, and edit the
trace setting for RTMT.
♦ Window-Allows you to close a single RTMT window or all RTMT windows.
♦ Application-Allows you to browse the web pages for Administration and Serviceability.
♦ Help-Allows you to access RTMT documentation online help or to view the RTMT version.
• Quick Launch Channel-Pane on the left side of RTMT window with tabs that you can click on to
display information on the server or information on the applications. The tab contain groups of icons
that you can click on to monitor various objects.
• Monitor pane-Pane where monitoring results display.
Related Topics

• How to Install and Upgrade the Real-Time Monitoring Tool (RTMT)
• Launching RTMT
• Getting More Information

How to Use RTMT Plug-Ins
• Downloading the Plug-In
• Accessing the Plug-In

Downloading the Plug-In
You can expand the functionality of RTMT by installing an application plug-in, such as the Voice Log
Translator (VLT) application. You can download the latest plug-ins for the RTMT viewer from Cisco.com.
After installing the plug-in, you can access the application in the RTMT viewer. This involves:
RTMT Interface

10

Cisco_Unified_Presence,_Release_7.x_--_How_To_Install_and_Configure_the_Real-Time_Monitoring_Tool_(RTMT)

Procedure

1. Select Application > CCO Webpage.
2. Perform the following actions when the Login Prompt displays:
1. Enter your Cisco.com user name and password.
2. Click OK.
3. Download the file to your PC.
4. Double-click the download file to begin the installation.
5. Follow the installation instructions.

Related Topics

• How to Install and Upgrade the Real-Time Monitoring Tool (RTMT)
• Getting More Information
What To Do Next

• Accessing the Plug-In

Accessing the Plug-In
Procedure

1. Perform one of the following actions:
1. Click the Tools tab and the Plugins tab in the Quick Launch Channel; and then click the icon
of the application in which you are interested.
2. Select System > Tools > Plug-in
2. Select the plug-in that you want to launch.

Related Topics

• Getting More Information
• Cisco Voice Log Translator User Guide

Procedure
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