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FAQs and Troubleshooting Guide for Cisco Services Ready
Engine Virtualization 1.5
Frequently Asked Questions
Note: Additional FAQs are provided in the ?Services Ready Engine Virtualization? section in Cisco Unified
Computing System Express at:
http://www.cisco.com/en/US/prod/collateral/contnetw/ps5719/ps11273/qa_c67-625001.html

Q. Is the vSphere Client bundled with the Cisco SRE-V software package?
A. No, the vSphere Client is not bundled with the Cisco SRE-V software package. You must download it
after you install Cisco SRE-V.
To download the vSphere Client, do the following:
1. Go to https://hypervisor-ip-address. You are directed to the VMware website, and the Welcome page
opens.
2. Click Download vSphere Client, and then click Run to download the vSphere Client. The VMware
vSphere Client is installed and a shortcut icon to the client appears on your desktop.
Note: To download the vSphere Client, connection to the Internet is required.

Q. How do I know which type of Cisco SRE Service Module is installed in the router
from a Microsoft Windows virtual machine?
A. To determine which type of Cisco SRE Service Module is installed in your router, do the following:
From the Microsoft Windows virtual machine, choose System > Properties. From the CPU and processor
information, you can determine the type of Cisco SRE Service Module, whether it is a Cisco SRE 700
Service Module or a Cisco SRE 900 Service Module:
• Cisco SRE 700 Service Module?Solo CPU and Processor Type L3400
• Cisco SRE 900 Service Module?Duo CPU and Processor Type L9400

FAQs and Troubleshooting Guide for Cisco Services Ready Engine Virtualization 1.5
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Q. What is the correct syntax for using the FTP credentials in the installation and
upgrade URL?
A. The correct syntax for using the FTP credentials in the installation URL is:

Router# service-module sm 2/0 install url ftp://username:password@server.com/dir/sre-v-k9-r.SPA.sm

The correct syntax for using the FTP credentials in the upgrade URL is:

Router# service-module sm 2/0 install url ftp://username:password@server.com/dir/sre-v-k9-r.SPA.sm

Q. How do I check the Cisco SRE-V software version?
A. To display the software version, use the service-module sm 1/0 status command from the host router.
Example:
Router# service-module sm 1/0 status
Service Module is Cisco SM1/0
Service Module supports session via TTY line 67
Service Module is in Steady state
Service Module heartbeat-reset is enabled
Getting status from the Service Module, please wait..
Cisco SRE-V Software 1.5.1.0
VMware ESXi 4.1.0 build-348481 running on SRE

Q. How do I enable Remote Tech Support (SSH) for a host?
A. You can enable SSH for a host from the DCUI or from the vSphere Client.
• To enable SSH for a host from the DCUI, press F2, and then choose Customize System >
Troubleshooting Mode Options > Enable Remote Tech Support (SSH).
• To enable SSH for a host from the vSphere Client, do the following:
- Choose the host for which you want to enable SSH.
- Click the Configuration tab. From the left pane, under Software, choose Security Profile.
- From the top right corner, choose Properties.
- Choose Remote Tech Support (SSH) > Options > Start.

Q. How do I start, stop, restart, or check the status of the RBCP Agent?
A. To start, stop, restart, or check the status of the RBCP Agent, do the following:
1. Enable Remote Tech Support (SSH) from the DCUI or the vSphere Client (see previous FAQ), and then
SSH to the host.
2. Do one of the following as appropriate:
• To start the RBCP agent, use the /etc/init.d/cisco-rbcp start command.

Q. What is the correct syntax for using the FTP credentials in the installation and upgrade URL? 3

Cisco_Services_Ready_Engine_Virtualization_1.5_--_Troubleshooting
• To stop the RBCP agent, use the /etc/init.d/cisco-rbcp stop command.
• To restart the RBCP agent, use the /etc/init.d/cisco-rbcp restart command.
• To check the RBCP agent current status, use the /etc/init.d/cisco-rbcp status command.

Q. How do I enable or disable the debug level logging for the RBCP Agent?
A. To enable or disable the debug level logging for the RBCP Agent, do the following:
1. Enable Remote Tech Support (SSH) from the DCUI or the vSphere Client, and then SSH to the VMware
vSphere HypervisorTM host.
2. Do one of the following as appropriate:
• To enable the debug level logging for the RBCP Agent, use the esxcfg-advcfg --user-var
CiscoRBCPDebugLevel --set-user-var 1 command.
• To disable the debug level logging for the RBCP Agent, use the esxcfg-advcfg --user-var
CiscoRBCPDebugLevel --set-user-var 0 command.
3. Reboot the VMware vSphere HypervisorTM host for the setting to take effect.

Q. How do I set the clock on the VMware vSphere Hypervisor?
A. To set the clock on the VMware vSphere HypervisorTM, you must add an NTP server to it using the
vSphere Client GUI. Do the following:
1. Click the Configuration tab.
2. From the left pane, under Software, choose Time Configuration. The Time Configuration window opens.
3. Choose Properties, and then choose Options. The NTP Daemon (ntpd) Options dialog box opens.
4. Choose NTP Settings, and then click Add. The Add NTP Server dialog box opens.
5. Add the IP address of the NTP Server in the Address field. After you add the NTP server, the clock on the
VMware vSphere HypervisorTM is set.

Q. How do I view RAID related events or errors in VMware vSphere Hypervisor
logs?
A. To display RAID related events or errors in VMware vSphere HypervisorTM logs, do the following:
1. From the vSphere Client GUI, choose View > Administration > System Logs.
2. Use the keyword promise to search and display RAID related events or errors.

Q. How do I create RAID logical volumes?
A. To create RAID logical volumes, complete the following steps:

Q. How do I start, stop, restart, or check the status of the RBCP Agent?
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1. Use the SSH Client software to log into the VMware vSphere HypervisorTM. Do the following:
a. For the hostname, enter the IP address of the VMware vSphere HypervisorTM or the DNS hostname.
b. If prompted to accept the server?s host key, click Yes.
c. Use root for the username.
d. When prompted for a password, do the following:
• If you are a first time user, leave the password empty by pressing Enter.
• If you have configured a password, enter that password, and then press Enter.
The following Tech Support Shell prompt appears:
~ #

2. At the Tech Support Shell prompt, use the promise-raid-cli command, and then press Enter. You enter
the RAID management command environment:
~ # promise-raid-cli
raid-cli>

3. To create logical volumes use one of the following commands as appropriate:
• Use the logdrv -a add -p 1,2 -e 0,0 -z ?raid=raid0,name=RAID0,init=quick? command to create a
simple block level striping RAID 0 volume.
• Use the logdrv -a add -p 1,2 -e 0,0, -z ?raid=raid1,name=RAID1,init=quick? command to create
a simple 1:1 mirrored RAID 1 volume.
Examples:
raid-cli> logdrv -a add -p 1,2 -e 0,0 -z ?raid=raid0,name=RAID0,init=quick?
raid-cli> logdrv -a add -p 1,2 -e 0,0, -z ?raid=raid1,name=RAID1,init=quick?

Q. How do I verify the RAID mode after installing Cisco SRE-V?
A. To verify the RAID mode after you have installed Cisco SRE-V, complete the following steps: 1. Use the
SSH Client software to log into the VMware vSphere Hypervisor. Do the following:
a. For the hostname, enter the IP address of the VMware vSphere Hypervisor or the DNS hostname.
b. If prompted to accept the server?s host key, click Yes.
c. Use root for the username.
d. When prompted for a password, do the following:
• If you are a first time user, leave the password empty by pressing Enter.
• If you have configured a password, enter that password, and then press Enter.

Q. How do I create RAID logical volumes?
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The following Tech Support Shell prompt appears:
~ #

2. At the Tech Support Shell prompt, use the promise-raid-cli command, and then press Enter. You enter the
RAID management command environment:
~ # promise-raid-cli
raid-cli>

3. From the RAID Management CLI, use the logdrv command to display RAID information.
Example:
raid-cli> logdrv
ID RAID Disks Sectors Size (MB)
DiskID Name
-----------------------------------------------------------------0 JBOD
1
64
476940.02
(1)
JBOD on port 01 (00)
1 JBOD
1
64
476940.02
(2)
JBOD on port 02 (00)

Q. How can I view the VMware vSphere Hypervisor logs and diagnostic information?
A. To view the VMware vSphere Hypervisor logsTM and diagnostic information, do one of the following:
• From the DCUI, press F2, choose Customize System > View System Logs, and then choose 1 to
display the messages.
• From vSphere Client, connect to the VMware vSphere HypervisorTM host, and then choose Home >
Administration > System Logs. Choose hostd.log and messages.log.
Note: Make sure that you follow this procedure from vSphere Client and not from vCenter.

Q. How can I view Cisco specific logs?
A. To view Cisco specific logs, look for specific tags in the RAID and RBCP Agent components:
For the RAID component, look for the promise tag.
For the RBCP Agent, look for the cisco_rbcp tag.
Example of the cisco_rbcp tag:
Jan
Jan
Jan

7 06:03:30 root: cisco_rbcp get_vswitch [vmnic1]
7 06:03:31 root: cisco_rbcp Running get_vswitch cmd[r:0]: /sbin/esxcfg-vswitch -l | grep vmni
7 06:03:31 root: cisco_rbcp get_vmk_in_vswitch [vSwitch0] [Management Network]

Q. How can I get the log files from the VMware vSphere Hypervisor host?
A. To get the log files from the VMware vSphere HypervisorTM host, do the following:
1. From the vSphere Client, connect to the VMware vSphere Hypervisor hostTM, and then choose Home >
Administration > System Logs.

Q. How do I verify the RAID mode after installing Cisco SRE-V?
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2. Choose Export Logs, which is located on top of the page. The logs are saved on the system that is running
the vSphere Client.
Note: Make sure that you follow this procedure from vSphere Client and not from vCenter.

Q. How can I view alerts and warnings in the vCenter Server?
A. To view alerts and warnings in the vCenter Server, do one of the following:
• Click the Alert icon, which is located in the top right corner of the page.
• Click the Alarm tab, and then click the Summary tab.
Note: Occasionally, when you click the Alarm tab, warnings might not be displayed. Therefore, we
recommend that you also click the Summary tab to view the warnings.

Q. How can I add an USB device to a Microsoft Windows virtual machine?
A. For information about how to add an USB device to a Microsoft Windows virtual machine, see the
following documents:
• For step-by-step instructions, see the USB Passthrough in vSphere 4.1 document, at:
http://vstorage.wordpress.com/2010/07/15/usb-passthrough-in-vsphere-4-1/
• For a list of VMware supported USB device models, see:
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1021345

Connectivity Issues Troubleshooting
Network Connectivity Failure After Installing the Operating System
Problem: After installing the operating system on a virtual machine, the system cannot connect to the
network.
Solution: To resolve this problem, do the following:
• Make sure that the network configuration includes a valid IP address.
• Make sure that the status of the virtual machine is Active. To view the status of the virtual machine,
choose the Activate button from the Network Configuration page.

Installation Troubleshooting
Microsoft Windows 2003 Installation Does Not Work
Problem: You cannot install Microsoft Windows 2003.

Q. How can I get the log files from the VMware vSphere Hypervisor host?
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Probable Cause: This problem could occur if you set the SCSI controller to LSI Logic SAS when creating a
custom virtual machine.
Solution: To resolve this problem, set the SCSI controller to LSI Logic Parallel. Do the following:
1. Right click the virtual machine, and then choose Edit Settings. The Virtual Machine Properties page
opens.
2. Choose SCSI Controller, and then click the Change Type button on the right pane. The Change SCSI
Controller Type page opens.
3. Choose LSI Logic Parallel, and then click OK.

Cannot View Datastore After Installing Cisco SRE-V
Problem: After installing Cisco SRE-V, the datastore is missing:
Solution: To resolve this problem, manually add the datastore. From the vSphere Client GUI Home page, do
the following:
1. Choose Inventory > Configuration.
2. From the Hardware pane (left pane), choose Storage.
3. Click the Add Storage... button. The Select Storage Type wizard page opens.
4. Follow the wizard steps to manually add the datastore to the inventory.
5. Click the Refresh and Rescan All... buttons. The datastore should now be visible from the Management
virtual machine.

Module Does Not Respond After Using the Cisco SRE-V Install or Uninstall
Commands
Problem: Occasionally, after using the Cisco SRE-V install or uninstall commands, the Cisco SRE Service
Module does not respond.
Solution: To resolve this problem, verify that the router is using the supported Cisco IOS version, which is
15.1(4)M or later. Use the show version command to verify the Cisco IOS version.
• If the Cisco IOS version that is installed on the router is not supported, install the appropriate Cisco
IOS version.
• If the Cisco IOS version that is installed on the router is supported, and the service module still does
not respond, reset the service module and then install Cisco SRE-V again. Use the service-module
sm slot/0 reset command to reset the service module:
Router# service-module sm 1/0 reset

Cisco SRE-V Installation Fails
Problem: Cisco SRE-V installation does not work.
Microsoft Windows 2003 Installation Does Not Work
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Solution: To resolve this problem, do the following:
• Make sure that you are able to ping the FTP server from the router.
• Make sure that the FTP server is able to reach the service-module ip address hypervisor-ip-address
subnet-mask that was configured on the router.
• Make sure that the appropriate installation files are in the FTP server:
- sre-v-k9-r.spa.smv.1.5.1.pkg?For Cisco SRE 900 Service Module
- sre-v-k9.spa.smv.1.5.1.pkg?For Cisco SRE 700 Service Module
• View the SRE installation log files to determine the cause of the installation failure. To view the SRE
installation log files, enter the following command:
Router# Debug sre-install all

• View the service module console log files to determine the cause of the installation failure. To view
the service module console log files, enter the following command after executing the installation
command:
Router# service-module sm slot/0 session

Cisco Management Console Disappears After Cisco SRE-V Installation
Problem: After installing Cisco SRE-V, the Cisco management console disappears and the VMware vSphere
Hypervisor Direct Console User Interface (DCUI) appears.
Probable Cause: This is expected behavior.
Note: If you are a first-time user of the VMware vSphere Hypervisor, use root for the username; and for the
password, leave the field empty. After you login, we recommend that you change the password.

Missing Virtual Machines After Cisco SRE-V Installation with keep-ds Argument
Problem: Virtual machines are missing from vSphere Client after using the service-module sm slot/0 install
url url argument keep-ds command to install Cisco SRE-V.
Probable Cause: This problem occurs because when you use the keep-ds argument with the installation
command, the datastores and the virtual machines are retained, but you must manually add the virtual
machines back into the inventory.
Solution: To manually add the virtual machines back into the inventory, do the following:
1. Choose Inventory > Configuration > Storage > Datastore.
2. Browse to the datastore for the appropriate virtual machine folder.
3. Right-click the vmx file, which is located in the virtual machine folder, and then choose Add to
Inventory. The virtual machines appear in the vSphere Client.

Cisco SRE-V Installation Fails
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New Virtual Machine Names Not Reflected After Cisco SRE-V Installation with
keep-ds Argument
Problem: After using the service-module sm slot/0 install url url argument keep-ds command to install
Cisco SRE-V, the renamed virtual machines change back to their original names.
Probable Cause: This is expected behavior. This problem occurs because when you use the keep-ds
argument with the installation command, disk data is retained but the vSphere Client is restored to its default
settings. Therefore, the names of the virtual machines change back to their original names.
Solution: Rename the virtual machines.

Virtual Machine Troubleshooting
Microsoft Windows License Activation Fails after Export and Import of the Virtual
Machine
Problem: You exported a virtual machine and then imported it back, and you noticed that the Microsoft
Windows software license activation failed. Further Problem Description: You purchased the Cisco SRE-V
Option 3 (Hardware, plus Virtualization software, plus Microsoft Windows software), and a virtual machine
was provided to you by default. Both the Virtualization software license and the Microsoft Windows
software license on this virtual machine were preactivated. You exported this virtual machine and then
imported it back, and you noticed that the Microsoft Windows software license activation failed.
Probable Cause: This problem could occur for the following reasons:
• Some of the configuration lines in the OVF file are missing.
• Some of the VMX file parameters are missing.
Solution: To resolve this problem, do the following:
• Manually add the following configuration lines to the OVF file in the Virtual Hardware section:
<VirtualHardwareSection>
....
....
<vmw:ExtraConfig vmw:key=?acpi.passthru.slic? vmw:value=?true?/>
<vmw:ExtraConfig vmw:key=?acpi.passthru.slicvendor? vmw:value=?true?/>
<vmw:ExtraConfig vmw:key=?smbios.addhostvendor? vmw:value=?true?/>

• Verify that the VMX file contains the following parameters. If these parameters are missing, you
must add them:
uuid.action = ?create?
pcie.reportDataLink= ?TRUE?

Cannot Modify the Advanced Settings Parameters in the vSphere Client
Problem: You cannot modify the Advanced Settings parameters.
Further Problem Description: From the vSphere client, go to Home > Inventory. From the left navigation
tree, click the host name. Click the Configuration tab. From the left pane, under Software, choose
Advanced Settings. The Advanced Settings page opens with several parameters. When you try to modify the
New Virtual Machine Names Not Reflected After Cisco SRE-V Installation with keep-ds Argument10
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Advanced Settings parameters, you notice that the OK button is disabled and you cannot modify the
parameters.
Cause: The Advanced Settings parameters are intentionally blocked by Cisco Systems because they contain
critical configuration, which you cannot modify.
Solution: There is no workaround.

Virtual Machine Cannot Mount the USB Thumb Drive
Problem: The virtual machine cannot mount the USB Thumb Drive.
Probable Cause: This problem occurs when the USB Thumb Drive that was used and formatted by a
Microsoft Windows virtual machine was again used on a Linux-based virtual machine.
Solution: Use a new USB Thumb Drive.

Cannot Activate the Microsoft Windows License on a Virtual Machine
Problem: You cannot activate the Microsoft Windows license on a virtual machine.
Solution: To resolve this problem, do the following:
1. Use the show oem marker command to verify the OEM marker.
2. Make sure that the virtual machine is not a third-party virtual machine.
3. Make sure that the virtual machine is installed by Cisco manufacturing or is imported using the recovery
DVD.
4. Make sure that the ACPIPassthrough setting is enabled in the virtual machine. To do so, check the
Microsoft Windows hardware vendor information or the vmx file.
If the virtual machine is exported and then re-imported, see the appropriate user documentation for the
procedure to enable the ACPI Passthrough setting.

vCenter Troubleshooting
Disconnected Host in vCenter Server
Problem: The host appears disconnected and is grayed out in the vCenter Server.
Solution: To resolve this problem, do the following:
1. Make sure that you can ping the host IP address.
2. Right-click the hostname, and then choose Connect.

Orphaned Virtual Machine in the vCenter Server
Problem: There is an orphaned and grayed out virtual machine in the vCenter Server.

Cannot Modify the Advanced Settings Parameters in the vSphere Client
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Solution: To resolve this problem, do the following:
1. Remove the virtual machine from the inventory. Right-click the virtual machine and then choose Remove
from Inventory.
2. Choose Inventory > Configuration > Storage > Datastore.
3. Browse to the datastore for the appropriate virtual machine folder.
4. Right-click the vmx file, which is located in the virtual machine folder, and then choose Add to
Inventory. The virtual machine that was grayed out is now active.

Cannot Connect to the vCenter Server
Problem: You cannot connect to the vCenter Server even though network connectivity is available.
Solution: To resolve this problem, do the following:
1. Open services in the PC that has the vCenter Server.
2. Manually start the vCenter Server service and then try to connect again.

RAID Troubleshooting
Cannot View Datastores
Problem: After disk migration, reboot, or Cisco SRE-V software upgrade, you are unable to view the
datastores in Inventory > Configuration > Storage.
Solution: To resolve this problem, do the following:
1. Rescan the system a couple of times. From the vSphere Client GUI Home page, do the following:
a. Choose Inventory > Configuration.
b. From the Hardware pane (left pane), choose Storage.
c. From the Datastores pane (right pane), choose Rescan All... (located on the upper right corner). The
Rescan dialog box opens.
d. Click OK.
2. If rescanning the system does not resolve the problem, do the following:
a. Choose Inventory > Configuration.
b. From the Hardware pane (left pane), choose Storage.
c. Click the Add Storage... button. The Select Storage Type wizard page opens.
d. From the right pane, choose Disk/LUN, and then click Next. The Select Disk/LUN wizard page opens.

Orphaned Virtual Machine in the vCenter Server
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e. From the right pane, choose a disk, and then click Next. The Select VMFS Mount Options wizard page
opens.
f. From the right pane, choose the Assign a New Signature radio button, and then click Next.
g. Choose Free Space, and then click Finish.
The missing datastores display with a modified name, which you can change. For example, Datastore_R0
displays as snap-XXXXX-datastore_R0; and datastore_R1 displays as snap-XXXXX-datastore_R1. To
change the name of the datastore, right-click the appropriate datastore, and the choose Rename.

Datastore Name is Displayed as snap-XXXXX-datastore_datastore_name
Problem: After adding a new datastore in vSphere Client, the datastore displays with the name:
snap-XXXXX-datastore_datastore_name.
Solution: This is a know problem. You can change the name of the datastore. To change the name,
right-click the appropriate datastore, and then choose Rename.

Rebuild Process Does Not Start
Problem: After hot-swapping the faulty RAID 1 disk drive, the rebuild process does not start.
Probable Cause: RAID configuration shows a new JBOD logical volume, which you must delete.
Solution: To resolve this problem, do the following:
1. From the RAID management CLI, use the logdrv command to view RAID configuration.
When the valid partition table appears on the newly inserted drive, you might notice that the RAID
configuration is unbalanced, as shown in the following example:
raid-cli> logdrv
ID
RAID
Disks
0
RAID1
2
1
JBOD
1

Sectors
64
64

Size (MB)
476876.00
476940.02

Disk ID
(-,2)
(1)

Name
RAID1
JBOD on port 01 (00)

where (-,2) RAID1 represents an unbalanced array; and ID 1 shows a new JBOD logical volume. JBOD
represents non-RAID, which you must delete.
2. Use the logdrv -a del -1 ID number of the JBOD command to delete the JBOD logical volume:
raid-cli> logdrv -a del -l 1

Note: -l in the command is lower case ?L? and stands for logical.
After the JBOD logical volume is deleted, the rebuild process starts automatically on the new disk drive.
The rebuild process might take approximately two hours to complete. You can continue to perform normal
system operations during the rebuild process.
Caution: Make sure that you do not unplug the functional disc drive during the rebuild process. If you do,
you will lose data.
Cannot View Datastores

13

Cisco_Services_Ready_Engine_Virtualization_1.5_--_Troubleshooting
3. If the rebuild process does not start automatically, use the rb -a start -l 0 -i 0 -p
ID_number_of_the_hard_drive_to_add_to_the_RAID1_volume -e 0 command:
raid-cli> rb -a start -l 0 -i 0 -p 1 -e 0

4. (Optional) To check the rebuild status, use the rb -a list command, as shown in the following example:
raid-cli> rb -a list
Rebuild is in progress 10% in logical drive with ID 0 on controller #0!

You can also check the rebuild status in syslog.

Rebuild Process Stuck
Problem: After removing and reinserting a disk drive, the rebuild process gets stuck.
Example:
Array #1 rebuilding progress: 5%

Solution: To resolve this problem, do the following:
1. Reload the Cisco SRE Service module to trigger a rebuild.
2. If reloading the module is not possible, use the logdrv -a del -l ID_number_of_reinserted_disk_drive -I 0
command to delete the logical drive of the newly inserted disk drive:
raid-cli> logdrv -a del -l 1 -I 0

3. If the rebuild process does not start automatically, use the rb -a start -l 0 -i 0 -p ID_number_of_RAID1 -e
0 to start the rebuild process:
raid-cli> rb -a start -l 0 -i 0 -p ?2? -e ?0?

Cannot Create Datastores on a Single Disk RAID 0 Array
Problem: Cannot create a datastore on a single disk RAID 0 array.
Solution: Use the init ?a start ?l 0 ?i 0 -q command on the logical drive where you want to create the
datastore.

RAID Troubleshooting Tips
Modifying RAID Configuration
If you are making any changes to the RAID configuration, make sure that you delete all datastores.
If you are using the RAID migration procedure to migrate between RAID levels, you do not need to delete
datastores.
Orphan Configuration in VMware
Rebuild Process Does Not Start
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Before using RAID management commands to change or delete a logical drive configuration, make sure that
you delete the associated datastore. If you do not delete the associated datastores, an orphan configuration
remains in the system.

Error Messages
Error Message: File or Directory on the Remote Server Cannot be Accessed
Problem: After entering the import command, you get the following error message:
File or directory on the remote server cannot be accessed.

Solution: To resolve this problem, do the following:
• Verify that the ftp server directory has read/write permissions.
• Verify that the username and password of the ftp server are correct.

Error Message: Aesop Application Error
Problem: Helper install fails and you get the following error message:
aesop application error.

Probable Cause: If the SATA mode of the Cisco SRE Service Module was previously set to IDE mode, and
then you try to install the Cisco SRE-V 1.5 software using the helper install, the installation fails. Cisco
SRE-V 1.5 is only functional when the SATA mode on the Cisco SRE Service Module is set to AHCI.
Solution: To resolve this problem, use the service-module sm slot/0 install url url argument
disk-cfg-mode={raid1 | raid0 | nonraid} command to install Cisco SRE-V 1.5. The Cisco SRE-V 1.5
installation automatically converts the SATA mode from IDE to AHCI.

RAID Troubleshooting Tips
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