Reporting: Reports Returning Partial or No Data

From DocWiki

Revision as of 18:26, 8 October 2010 by Ccosenti (Talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Reports Returning Partial or No Data

Problem Summary Unified Expert Advisor reports are not returning any data or are returning only partial data.
Error Message There is no indication in CUIC other than no or partial data.

The logs may show errors similar to the following:

0000000027: 192.168.0.1: Dec 25 2010 08:39:08.939 -0700: %_RECOVERYLISTENERADAPTER-3-org.apache.activemq.store.amq.RecoveryListenerAdapter: Message id ID:server01user01-32948-76257652765276-5:7:2:1:5 could not be recovered from the data store - already dispatched

Possible Cause The JMS message store is corrupted.
Recommended Action
  1. Stop the runtime service on the Primary Runtime with the CLI command utils service stop "Expert Advisor Runtime Service".
  2. Stop the runtime service on the High Availability Server with the CLI command utils service stop "Expert Advisor Runtime Service".
  3. Stop the reporting service on the Reporting Server with the CLI command utils service stop "Expert Advisor Reporting Service".
  4. Run the CLI command utils expertadvisor clearpersistentstore
  5. Start the primary runtime, high availability runtime, and reporting services:
    1. Primary: utils service start "Expert Advisor Runtime Service".
    2. High Availability: utils service start "Expert Advisor Runtime Service".
    3. Reporting: utils service start "Expert Advisor Reporting Service"
Release Release 7.6(1)
Associated CDETS # None.

Rating: 0.0/5 (0 votes cast)

Personal tools