Cucm-phone-locale-installers

From DocWiki

Revision as of 21:21, 7 April 2011 by Qingche (Talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Cisco Unified Communications Locale Installer Frequently Asked Questions (FAQ)

Locale Types

Locales for Cisco Unified Communication Manager (CUCM): User Locale, Network Locale

Locales for Cisco Unified Presence (CUP): User locale

Locales for Cisco IP Phone Only: Phone Only locale

User Locale: includes localized user interfaces for applications, devices and services, and localized spoken prompts. CUCM User locales also include the Network Locale for the same country.

Network Locale: includes localized telephone and gateway tones.

Phone Only Locale: includes localized device user interfaces and tones.

Locale Installer (LI) Releases

There are Locale Installer (LI) releases for every CUCM and CUP major and minor releases. Usually, there is no LI release for CUCM and CUPS maintenance or service releases.

Q: What Version of Locale Installer should I apply when I upgrade my CUCM?

General rule: Apply the latest Locale Installer release that matches the major.minor number of your CUCM. Released locale installers are available on cisco.com. Locate the latest LI with a major.minor number that matches your CUCM or CUP major.minor number. For example, the latest locale installer for CUCM 6.1.x is LI 6.1.3.1000-1 (as of December 2009). Here are some exceptions for the matching "major.minor" number rule:

  • For CUCM release CUCM 6.1.2.1104-1, and any CUCM 6.1 releases after CUCM 6.1.2.1104-1, please use locale version 6.1.3.x.
  • CUCM 7.1.1 and CUCM 7.1.2 work only with LI 7.1.2.x. CUCM 7.1.3 and onwards work only with LI 7.1.3 and later release LI 7.1.x.

Q: What type of Locale do I need to install?

You will need: CUCM User Locale for every CUCM server, CUP user locale for every CUP server. If you need network tones for countries which we have no supported User Locale yet, you will need to apply the Combined Network Locale Installer on every CUCM server.

Q: Do locales need to be installed on every Node?

Cisco Unified Communications Locale Installer MUST be applied to each and every Cisco Unified Communications Manager server in a cluster, starting with the publisher. After installation has completed, it is essential to reboot each and every platform in order for all user and network locale changes to become fully activated.

Q: How to install locales?

Locale can be installed either from Network drive or from CD/DVD drive.

Options A: Install locale from network drive:

  1. Put the locale installer (*.cop.sgn) file on an FTP or SFTP server that the server you can access.
  2. Log into Cisco Unified Communications Operating System Administration.
  3. Navigate to Software Upgrades > Install/Upgrade. The Software Installation/Upgrade window displays.
  4. Choose Remote Filesystem from the Source list.
  5. Enter the path to the directory that contains the local installer file on the remote system in the Directory field.
    If the upgrade file is located on a Linux or Unix server, you must enter a forward slash at the beginning of the directory path. For example, if the upgrade file is in the "patches" directory, you must enter "/patches". If the upgrade file is located on a Windows server, check with your system administrator for the correct directory path.
  6. In the Server field, enter the server name or IP address.
  7. In the User Name field, enter your user name on the remote server.
  8. In the User Password field, enter your password on the remote server.
  9. Select the SFTP protocol from the Transfer Protocol field.
  10. To continue the upgrade process, click Next.
  11. Choose the upgrade version that you want to install and click Next.
  12. In the next window, monitor the progress of the download.
  13. When the download completes, verify the checksum value against the checksum (if available) or the file you that downloaded that is shown on Cisco.com.
  14. Restart CUCM or CUP server after new locale/ locales has/have been installed.

Option B: Install locale from CD/DVD:

  1. Burn the locale installer file into a CD/DVD.
  2. Follow the steps in "Install locale from network drive" except "Choose CD/DVD from the Source list" instead of "Choose Remote Filesystem from the Source list."

Q: How to use Phone Only Locales (POLI)?

Cisco Unified Communications Locale Installer for Cisco Unified IP Phones ensures localised phones are kept up-to-date with the latest dictionaries after the firmware is upgraded. The full Cisco Unified Communications Locale Installer for Cisco Unified Communications Manager must be installed prior to installation of a Phone Only locale installer. For example, with CUCM 5.1 and Firmware 8.4.3, CUCM LI 5.1.x need to be installed first, then install Phone Only LI 8.4.3 for firmware updates.

Q: Do I need to install a new Phone Only locale every time after I upgrade my IP phone firmware?

Cisco only releases Phone Only Locales for FW with changes on phone dictionaries or internationalization. In another words, we do not have Phone Only Locale Installer release for every FW release when it is not necessary. When customer upgrades the firmware without upgrade their CUCM, they should install the latest Phone Only locale with the same major.minor number with the new FW. For example, if you upgrade the from FW 8.5.3 (with POLI 8.5.3) to FW 8.5.4, Phone Only Locale Installer 8.5.3 is also good for FW 8.5.4. If they upgrade FW from 8.5.4 to 9.0.1, you will need to install POLI 9.0.1.


Phone Only locale installer (PO LI) is a subset of the CUCM LI. PO LI is used for customers who upgrade IP phone firmware without upgrading CUCM.

Here is the version mapping between CUCM LI and PO LI:


CUCM LI Version (match the CUCM version major.minor)

PO LI version (matches the IP phone firmware version major.minor)
CUCM LI 8.5.x PO LI 9.1.x
CUCM LI 8.0.x PO LI 9.0.x
CUCM LI 7.1.x PO LI 8.5.x
CUCM LI 7.0.x PO LI 8.4.x
CUCM LI 6.1.x PO LI 8.3.x



Q: Where can I find language or device localization matrix?

IP Phone localization matrix and CUCM localization Matrix: http://docwiki-dev.cisco.com/wiki/IPCBU_Languages


Q: Does the Locale Installer register with the DRS for backup and restore?

Locale Installers, from version 5.1.1.1-1 onwards, no longer register with the DRS for backup and restore.

- The following command can be used to unregister locale components before migration from CUCM 5.1.1 to a higher version:

/var/log/active/installed_options/localeinstaller/locale_drf_reg.sh unregister 


Rating: 3.5/5 (8 votes cast)

Personal tools